Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 01-17-2018, 01:37 AM
antdaddy antdaddy is offline
Liking the Ford Ranger Forum
 
Join Date: Apr 2017
Posts: 16
Lightbulb 2000 3.0 #2 misfire solved

Recently my 2000 XLT Ranger 3.0 had a few problems. I purchased this truck with a4ld tranny swap. The previous owner didn't finish tightening all the bolts on the hell housing. This caused my flywheel to break I think. I fixed this and got it running. Then I noticed a misfire without any mil set. I started the truck then pulled each plug wire one at a time. #2 cylinder made no difference when disconnected and had spark. After swapping plugs and wires around nothing changed. I suspected the injector so I removed it and it was stuck . I cleaned it and installed it. Still no fix. So I swapped the #2and 3 injectors nothing still. I was baffled .

I could hear a knock sometimes usually after a test drive but it was unusual and would come and go. I took my wife's stethoscope and pressed it against the passenger side valve cover. I t was louder above the misfirring cylinder. I was sure a head job was next. I removed the valve cover and there it was the push rod for the intake on #2 wasn't set in the rocker arm! I have never seen this happen before. I don't know what caused this to happen.Everything was clean and appeared great. I checked the push rod for bends , it was all good. I tightened the fulcrum bolt back down on that rocker and found another loose one. That was it running great again.

I would like to know what caused that to happen. The engine looked very clean internally .Could be a engine swap my odometer shows around 120000 miles. And I have been told the original owners ran from the law in this truck . I would think there would be some wear internally.

Any suggestions on the cause?
__________________
2000 Ranger XLT 44 , 3.0liter, Automatic Transmision, Black,
Reply With Quote
Reply

Tags
head, misfire, push rod

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
2000, 4.0 OHV help troubleshooting misfire/stutter ddietz 4.0 SOHC / 4.0 OHV Tech 80 12-26-2014 04:25 PM
Cylinder 5 Misfire - hard misfire at highway speeds, no smoke, no overheating LoveMyTruckNBama General Tech 2 12-04-2014 04:44 AM
2000 V6 3.0 Misfire and Gas Smell CTL408 3.0 Vulcan Tech 8 09-10-2014 06:16 AM
Misfire on #6 with 2000 flex fuel okcutiger 3.0 Vulcan Tech 6 01-15-2013 10:15 PM
2000 ford ranger 3.0 v6 flex fuel misfire cylinder 3 smackdaddyfresh 3.0 Vulcan Tech 17 12-17-2012 06:26 PM