Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 10-18-2017, 03:04 PM
ranger0909 ranger0909 is offline
Learning to use the forums
 
Join Date: Oct 2017
Posts: 2
Default Lean Code, Misfires, Slipping Transmission

So about 2 months ago i was getting ready for my annual trip from Florida to Michigan. My ranger is a 2003 3.0 V6 191,xxx. Needless to say, the day before i left for Michigan i replaced the very corroded positive battery terminal connection, cleaned and oiled the K&N air filter, and cleaned the engine bay with some cleaner and a light spray setting of the hose. The truck was running perfectly before doing these 3 things. After cleaning the engine i allowed it to dry for about an hour and then drove around the block. I immediately noticed the truck was driving differently. The engine seemed to have less power, and the transmission was shifting very hard and late. Regardless of that i left the next morning and on the drive to Michigan i noticed very lacked power especially climbing the hilly regions. The truck would drop to 45-50 mph when going up steep grades and the CEL would flash indicating a misfire. When i got to Michigan and scanned for codes i received a Lean Bank 1, Misfire Cyl. 4, 5,6. Over the past two months this problem has persisted and the transmission is now slipping out of gear at low speeds. Anytime i get to around 3500 RPM on the freeway is the only time i get a CEL flashing.
I have completed the following to no avail:
Cleaned MAF
Tested Plug Wires (did not pull plugs)
Replaced Coil Pack
Checked Trans fluid

I Don't know if the Loss of Acceleration power problem and transmission problem are related but they sure seem to have presented themselves at the same time.

Any insight anyone has would be appreciated, Broke College Kid trying to avoid taking it into a shop.
Reply With Quote
  #2  
Old 10-19-2017, 12:04 AM
Undrstm8ed Undrstm8ed is offline
Habenae Est Dominatus
 
Join Date: Apr 2013
Posts: 1,247
Default Re: Lean Code, Misfires, Slipping Transmission

Have you left the MAF unplugged to see if it corrects itself?

And you went out of your way to change out a $45 coil pack but not $12 in plugs first? Have you since then checked them at least?
__________________
"Your right, there is no "I" in Team But there sure is in Independence, Individuality, and Integrity.."

- 93' Ranger, Overland Build thread http://www.fordrangerforum.com/proje...ing-build.html
Reply With Quote
  #3  
Old 10-19-2017, 07:49 AM
ranger0909 ranger0909 is offline
Learning to use the forums
 
Join Date: Oct 2017
Posts: 2
Default Re: Lean Code, Misfires, Slipping Transmission

Coil pack was cracked, needed replacing anyways. Only reason i didn't pull all plugs was because they were new less than 5,000 miles ago. Since then i have pulled them, they are clean and sparking just fine.
Reply With Quote
  #4  
Old 10-19-2017, 10:05 PM
Undrstm8ed Undrstm8ed is offline
Habenae Est Dominatus
 
Join Date: Apr 2013
Posts: 1,247
Default Re: Lean Code, Misfires, Slipping Transmission

and the MAF unplugged results?
__________________
"Your right, there is no "I" in Team But there sure is in Independence, Individuality, and Integrity.."

- 93' Ranger, Overland Build thread http://www.fordrangerforum.com/proje...ing-build.html
Reply With Quote
  #5  
Old 10-22-2017, 01:05 PM
idahoRedRanger idahoRedRanger is offline
Broke Car Enthusiast
 
Join Date: Oct 2013
Posts: 430
Default Re: Lean Code, Misfires, Slipping Transmission

Did you redo the terminal correctly? Everything all crimped and what not?
__________________
Project log
99 Ford Ranger XLT Sport 3.0L
Autobot name:Rubeo Bestia(latin for little red beast)
135 amp alternator, 4.0 air intake tube, air box mod, 235/75-15 Hankook Dynapro, 01-03 conversion, buggman LEDs, throttle cable mod
I take photos for fun
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Lean code and fuel circuit code louisvilleranger95 4.0 SOHC / 4.0 OHV Tech 14 02-06-2017 01:01 PM
Stupid lean code fix Doctor Wily 4.0 SOHC / 4.0 OHV Tech 0 09-21-2016 04:13 PM
p0171 lean code won't go away kaotkbliss 4-Cylinder Tech 9 07-21-2016 03:48 PM
Check Engine Light Code 01 too lean??? 577-Jersey 4.0 SOHC / 4.0 OHV Tech 4 09-30-2015 04:32 PM
3.0 bank1 lean code please help fomospede 3.0 Vulcan Tech 4 01-29-2011 07:48 AM