Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 09-07-2017, 04:52 PM
womack womack is offline
Learning to use the forums
 
Join Date: May 2016
Posts: 7
Default 3.0 ranger trouble with power

I have a 2000 ford ranger an had a code for the camsyncisor i replaced it an low end powers is alot better. still dont have any power after 3rd gear wants to fall on its face an the code keeps comeing back up even after resetting it. does anyone have any sugestions.
__________________
I have a standered 3.0 for ranger looking to make it better.
Reply With Quote
  #2  
Old 09-07-2017, 07:20 PM
Grumpa Grumpa is offline
Busted Knuckles
 
Join Date: Mar 2016
Posts: 210
Default Re: 3.0 ranger trouble with power

Did you replace just the sensor on top or the whole synchronizer with the sensor?
__________________
1995 Ranger XLT 3.0L OBDII
Trans: A4LD (E) 2WD
Rear: 7.5 / 3.45 NL LHD
Tires:GY P235 75/R15 (orig 225 70/R14)
Long Bed, 20 Gal Tank
Up to 225,500 miles

Last edited by Grumpa; 09-07-2017 at 07:20 PM. Reason: syntax
Reply With Quote
  #3  
Old 09-08-2017, 06:52 AM
womack womack is offline
Learning to use the forums
 
Join Date: May 2016
Posts: 7
Default

Quote:
Originally Posted by Grumpa View Post
Did you replace just the sensor on top or the whole synchronizer with the sensor?
I replaced everything

----------

Quote:
Originally Posted by womack View Post

I replaced everything
I was thinking maybe the cam is wore out but I don't wanna tear into it if thays not the problem. Don't really have the money to play hit an miss problems
__________________
I have a standered 3.0 for ranger looking to make it better.
Reply With Quote
  #4  
Old 09-08-2017, 07:33 AM
CalebJ CalebJ is online now
Ford Pickup
 
Join Date: Jul 2017
Posts: 103
Default Re: 3.0 ranger trouble with power

How's the compression? Fuel pressure? Any other codes? Recent tune up?
__________________
1999 3.0 FFV 4wd Ext. Cab
Reply With Quote
  #5  
Old 09-08-2017, 11:09 AM
womack womack is offline
Learning to use the forums
 
Join Date: May 2016
Posts: 7
Default

Quote:
Originally Posted by CalebJ View Post
How's the compression? Fuel pressure? Any other codes? Recent tune up?
I did a tune up on it wires, an plugs went back with factory plugs. Compression is something I haven't checked. Cylinder to was to lean replaced the wires when that came up. An it went right back to the cam senor an sync
__________________
I have a standered 3.0 for ranger looking to make it better.
Reply With Quote
  #6  
Old 09-08-2017, 11:12 AM
CalebJ CalebJ is online now
Ford Pickup
 
Join Date: Jul 2017
Posts: 103
Default Re: 3.0 ranger trouble with power

Quote:
Originally Posted by womack View Post
An it went right back to the cam senor an sync
Are you saying that the error code for the cam sensor and synchronizer came back? If so, that points to an improper installation. If you're not sure that it's at the right point, one of the plastic insert tools will help you ensure getting it installed properly.
__________________
1999 3.0 FFV 4wd Ext. Cab
Reply With Quote
  #7  
Old 09-08-2017, 12:20 PM
womack womack is offline
Learning to use the forums
 
Join Date: May 2016
Posts: 7
Default

Quote:
Originally Posted by CalebJ View Post
Are you saying that the error code for the cam sensor and synchronizer came back? If so, that points to an improper installation. If you're not sure that it's at the right point, one of the plastic insert tools will help you ensure getting it installed properly.
When. I put it back togather I had everything marked an transfered all the markings onto the new shaft. It fires right up with no trouble so that's why I'm lost
__________________
I have a standered 3.0 for ranger looking to make it better.
Reply With Quote
  #8  
Old 09-08-2017, 12:23 PM
MaDMaXX MaDMaXX is offline
Ford Tough
 
Join Date: Jul 2017
Posts: 278
Default Re: 3.0 ranger trouble with power

So again, does the code still show up?
Did you clear the code after replacing the part?
__________________
2002 V6 3.0 Ranger Edge 2WD

Repairs/Upgrades/New Stuff Log
Reply With Quote
  #9  
Old 09-08-2017, 12:54 PM
Grumpa Grumpa is offline
Busted Knuckles
 
Join Date: Mar 2016
Posts: 210
Default Re: 3.0 ranger trouble with power

Double check the position of the cam synch. Bring the #1 cylinder up to TDC and then remove the sensor and see where the notch in the synch is located. It will at least either confirm proper install or the problem.
__________________
1995 Ranger XLT 3.0L OBDII
Trans: A4LD (E) 2WD
Rear: 7.5 / 3.45 NL LHD
Tires:GY P235 75/R15 (orig 225 70/R14)
Long Bed, 20 Gal Tank
Up to 225,500 miles
Reply With Quote
  #10  
Old 09-08-2017, 12:56 PM
womack womack is offline
Learning to use the forums
 
Join Date: May 2016
Posts: 7
Default

Quote:
Originally Posted by MaDMaXX View Post
So again, does the code still show up?
Did you clear the code after replacing the part?
Yes I cleared all codes by removing the battery cables an removing the plug to the brain. I'll pull the sycornizer an see what happens

----------

Quote:
Originally Posted by Grumpa View Post
Double check the position of the cam synch. Bring the #1 cylinder up to TDC and then remove the sensor and see where the notch in the synch is located. It will at least either confirm proper install or the problem.
I'll do that. Ty
__________________
I have a standered 3.0 for ranger looking to make it better.
Reply With Quote
  #11  
Old 09-08-2017, 01:35 PM
CalebJ CalebJ is online now
Ford Pickup
 
Join Date: Jul 2017
Posts: 103
Default Re: 3.0 ranger trouble with power

Please, please, answer the questions we're asking so we can actually help you.

Is the code still there? Are any other codes still there?
__________________
1999 3.0 FFV 4wd Ext. Cab
Reply With Quote
  #12  
Old 09-08-2017, 03:22 PM
womack womack is offline
Learning to use the forums
 
Join Date: May 2016
Posts: 7
Default

Quote:
Originally Posted by CalebJ View Post
Please, please, answer the questions we're asking so we can actually help you.

Is the code still there? Are any other codes still there?
No there are not any other codes.
__________________
I have a standered 3.0 for ranger looking to make it better.
Reply With Quote
  #13  
Old 09-08-2017, 04:56 PM
CalebJ CalebJ is online now
Ford Pickup
 
Join Date: Jul 2017
Posts: 103
Default Re: 3.0 ranger trouble with power

And the original code for the cam position sensor?
__________________
1999 3.0 FFV 4wd Ext. Cab
Reply With Quote
  #14  
Old 09-10-2017, 07:43 AM
womack womack is offline
Learning to use the forums
 
Join Date: May 2016
Posts: 7
Default

Quote:
Originally Posted by CalebJ View Post
And the original code for the cam position sensor?
The code is a p0340 camshaft position sensor. I cleared everything an it came back not 50 miles after changing it. It is the only code that (Auto Zone ) comes up
__________________
I have a standered 3.0 for ranger looking to make it better.
Reply With Quote
  #15  
Old 09-10-2017, 01:43 PM
Birchhatchery Birchhatchery is offline
Ford Pickup
 
Join Date: Mar 2011
Posts: 120
Default Re: 3.0 ranger trouble with power

i had same code I changed mine and the code went away I don't no what kind you bought cuz they had new synchronizers from 25-80 dollars I found when I did mine the 25 dollar ones would not fit i got one from Napa 75 dollars and it fit fine my code went away maybe its because of a cheap cam sync or you did not get it in exactly the same way would be my guess
__________________
God Bless Donald Trump ! 2020!
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Lack of power/ shaking/ timing trouble joeboater83 3.0 Vulcan Tech 1 10-09-2017 10:45 AM
2.9 liter engine trouble no power dadsproject 2.9 Liter Tech 2 11-05-2013 05:28 PM
Trouble with power locks nelson22 Exterior Tech 3 09-23-2012 11:45 AM
Ranger trouble, money trouble, is the solution an older Ranger? jcfleck General Ford Ranger Discussion 9 11-23-2011 11:59 AM
Trouble with brakes dragging? Trouble engaging clutch! 96DangerRanger Drivetrain Tech 2 08-16-2011 02:05 PM