Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 08-19-2017, 05:01 PM
joeboater83 joeboater83 is offline
Learning to use the forums
 
Join Date: Aug 2017
Posts: 1
Default Lack of power/ shaking/ timing trouble

I have 94 3.0L
I did full tune up when i got it.
It suddenly has a shake to it and seems more sluggish than normal.
I had a few times it did not want to start i checked wires and wiggle tested ignition compoenents and could always get to start.
Did die on me once was coil replaced and fine.
Replaced ICM to see if fixed intermittant no start.
Then finally died on way home last week, pulled distributor to change pickup coil, damaged gear so replaced whole distributor, now running again but when i try to time per manual at 10btdc runs like crap almost dies. put at 15 to 20 seems to run better. Any ideas?
Also changed egr valve had some improvment but since back to normal.
thinking to change back presure sensor. any tests for o2 i can do, or cat?
compression at 150
Thanks..
__________________
1994 XLT 3.0L
Reply With Quote
  #2  
Old 10-09-2017, 10:45 AM
Miami592 Miami592 is offline
Learning to use the forums
 
Join Date: Mar 2015
Posts: 12
Default Re: Lack of power/ shaking/ timing trouble

How many miles? Has the timing chain ever been replaced?
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
misfire/lack of power/no power 4x4MAZDAB400094 4.0 SOHC / 4.0 OHV Tech 6 04-29-2014 08:22 AM
Lack of power jae4879 4.0 SOHC / 4.0 OHV Tech 14 06-30-2013 09:50 AM
Lack of power mikten 3.0 Vulcan Tech 12 06-01-2013 06:01 PM
Lack of power wyattj44 4.0 SOHC / 4.0 OHV Tech 30 08-01-2012 06:06 PM
3.0 Lack of Power rgrindle 3.0 Vulcan Tech 5 08-11-2011 08:28 PM