Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 05-22-2016, 07:39 AM
jw7783 jw7783 is offline
Liking the Ford Ranger Forum
 
Join Date: May 2016
Posts: 18
Default 97 3.0 Won't Start

Picked up 97 3.0 not running guy said it needs temp sensor and sending unit. It should still run with bad temp sensor correct? And also, sending unit is in tank but is the pump attached to it? The ones I've seen online dont have a pump on them. Never messed with these trucks before so just wondering what to expect
Reply With Quote
  #2  
Old 05-22-2016, 10:54 AM
jw7783 jw7783 is offline
Liking the Ford Ranger Forum
 
Join Date: May 2016
Posts: 18
Default

Well checked it out, PO welded braces in cant get tank out without pulling wheel, he snapped a green plastic piece (vent?) on top and sending unit is so rusted i cant get it out since its epoxied in. Is there a shorter version of tank i could use, say from a reg cab truck?
Reply With Quote
  #3  
Old 05-22-2016, 11:53 AM
bigfisher bigfisher is offline
Mustang Owner
 
Join Date: Mar 2012
Posts: 14,055
Default

Sounds like hes rigged the truck up pretty well and lost the locking ring. Try and find another 19.5 gallon tank.
__________________
2017 Lightning Blue Mustang GT PP 430/402
CJ Pony Parts Lowering Springs | Texas Speed Longtubes | PMAS CAI | Lund Tuned | Borla S-Type Catback
2013 F150 FX4 5.0 - Sold
1998 Jeep Wrangler TJ 4.0 5spd - Sold
2001 Mustang Bullitt - Sold
2005 Level II - Sold
2001 Integra GSR - Sold
1999 XLT - May 2013 TOTM - Totaled

Quote:
Originally Posted by 2004 fx4 level II
fuckin Nissan shhhiitttttttttt!!!!!!!!!!!!!!!!!!
Reply With Quote
  #4  
Old 05-22-2016, 07:04 PM
jw7783 jw7783 is offline
Liking the Ford Ranger Forum
 
Join Date: May 2016
Posts: 18
Default

Ya thats what im doing now. Any idea if a tank from a 98 will work? It doesnt matter if tank is smaller just want to make sure plugs will match up.
Reply With Quote
  #5  
Old 05-22-2016, 07:43 PM
bigfisher bigfisher is offline
Mustang Owner
 
Join Date: Mar 2012
Posts: 14,055
Default

A 98 tank will work but I think you mean fuel pump when you say plugs. If you swap tanks I would go get a new pump for your specific truck regardless.
__________________
2017 Lightning Blue Mustang GT PP 430/402
CJ Pony Parts Lowering Springs | Texas Speed Longtubes | PMAS CAI | Lund Tuned | Borla S-Type Catback
2013 F150 FX4 5.0 - Sold
1998 Jeep Wrangler TJ 4.0 5spd - Sold
2001 Mustang Bullitt - Sold
2005 Level II - Sold
2001 Integra GSR - Sold
1999 XLT - May 2013 TOTM - Totaled

Quote:
Originally Posted by 2004 fx4 level II
fuckin Nissan shhhiitttttttttt!!!!!!!!!!!!!!!!!!
Reply With Quote
  #6  
Old 05-23-2016, 05:11 AM
jw7783 jw7783 is offline
Liking the Ford Ranger Forum
 
Join Date: May 2016
Posts: 18
Default

Ya theres a 3 wire plug i believe on top of sending unit. Ill take a better look today. These trucks dont have a fuel cutoff/ inertia switch do they?
Reply With Quote
  #7  
Old 05-23-2016, 06:46 AM
bigfisher bigfisher is offline
Mustang Owner
 
Join Date: Mar 2012
Posts: 14,055
Default

Quote:
Originally Posted by jw7783 View Post
Ya theres a 3 wire plug i believe on top of sending unit. Ill take a better look today. These trucks dont have a fuel cutoff/ inertia switch do they?
yea passenger floorboard
__________________
2017 Lightning Blue Mustang GT PP 430/402
CJ Pony Parts Lowering Springs | Texas Speed Longtubes | PMAS CAI | Lund Tuned | Borla S-Type Catback
2013 F150 FX4 5.0 - Sold
1998 Jeep Wrangler TJ 4.0 5spd - Sold
2001 Mustang Bullitt - Sold
2005 Level II - Sold
2001 Integra GSR - Sold
1999 XLT - May 2013 TOTM - Totaled

Quote:
Originally Posted by 2004 fx4 level II
fuckin Nissan shhhiitttttttttt!!!!!!!!!!!!!!!!!!
Reply With Quote
  #8  
Old 05-23-2016, 05:27 PM
jw7783 jw7783 is offline
Liking the Ford Ranger Forum
 
Join Date: May 2016
Posts: 18
Default

It runs but not good. Dropped tank wiggled plug on it. Fuel pump kicked on with key. Looked for inertia switch but it was gone, 2 of the wires were wrapped together 3rd wasnt so i wrapped that with others and it started but bogged out if you hit gas. Pulled air filter it was a little better not much. Ran it with intake tube off throt body was better but would stall out. Unplugged MAF and other sensor and took whole tube out and it ran real good, it just idled at 2500-3000. But i could rev it up with no issues. Does this mean one or both sensors could be bad? Also going to include pic of a broken connector I believe was for a/c which is long gone.
Attached Images
File Type: jpg image-691376116.jpg (76.6 KB, 4 views)
Reply With Quote
  #9  
Old 05-29-2016, 04:44 PM
jw7783 jw7783 is offline
Liking the Ford Ranger Forum
 
Join Date: May 2016
Posts: 18
Default

Got a new Idle charge sensor? (Small sensor in intake tube) didnt change it only way i can get it to run is turning key on to prime system repeatedly and it'll run 20-30 seconds and stumbles out. Pulled lines off sending unit and a ton of gas from feed line poured out. Seems like pump doesnt have enough power to push gas once its running. I hooked power to pump out of tank and it kicks on but couldnt feel any pressure from either of the nipples on top of sending unit
Reply With Quote
  #10  
Old 06-24-2016, 06:29 PM
jw7783 jw7783 is offline
Liking the Ford Ranger Forum
 
Join Date: May 2016
Posts: 18
Default

Update. Tested iac valve it was good. Put in new sending unit and pump. Barely ran, unplugged maf and it ran good idles a bit high but as soon as i plug it in it cuts out and dies. Unplugged it and took it on 2 short trips in woods and it ran good stumbles a bit so i ordered new maf just waiting on delivery
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
1991 ford ranger won't start and when it did start it dint want stay running gann91fordrangerv6 General Tech 0 08-22-2014 08:33 AM
Truck won't Re-Start hot...but will start hours later? WTF? 02Edge 3.0 Vulcan Tech 31 12-27-2013 05:24 AM
Alarm won't shut off, car won't start bassfisherpaxton Electrical Tech 4 08-31-2011 03:24 PM
alarm won't shut off, truck won't start madamom Electrical Tech 3 04-04-2010 08:25 PM
Truck won't start in park... and won't engage into Drive Steve G. Drivetrain Tech 3 08-29-2009 06:41 PM