Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 08-18-2015, 08:55 AM
Nola_Son Nola_Son is offline
Learning to use the forums
 
Join Date: Aug 2015
Posts: 3
Default "Chattering" when accelerating, can't top 55mph

First time posting, but have been using this site as a source for a while now so thanks to you all,

2000 Ford Ranger, v6, 4.0

2 Issues:

1) When I accelerate, especially when going uphill, there is a "chattering" in the engine. It almost sounds metallic at this point. I had a full tune up not even a year ago (<10K miles).

2) Replaced the water pump last week and have had another leak that is causing a lot of steam to come out... trying not to take it in for this, but can't pinpoint the leak. Anyone else had a similar experience?

Thanks in advance. Take it easy on me.

Last edited by Nola_Son; 08-18-2015 at 11:34 AM. Reason: Edit: it's a 4.6L
Reply With Quote
  #2  
Old 08-18-2015, 10:13 AM
mms1361 mms1361 is offline
Ford Ranger Driver
 
Join Date: Apr 2012
Posts: 624
Default Re: "Chattering" when accelerating, can't top 55mph

1. chattering=engine pinging under load. Cheapest way to make it "go away" is to use higher octane fuel. Double check your coilpack and all -spark- components.
http://www.misterfixit.com/deton.htm

2.Some tips: Use a UV light/dye to help pinpoint the leak. See where the water accumulates. Check for pinholes in hoses while the engine is running. Some leaks only occur with the engine running because it adds pressure.
Other than that, its going to be near impossiblefor us to pinpoint the leak for you.
__________________
'00 Ranger, supercab, flareside, 2wd, 3.0, auto, 3.73 open, Bilstein 4600s, 31x10.5x15 BFGs, 15x8 procomp 152s
Reply With Quote
  #3  
Old 08-18-2015, 10:42 AM
Nola_Son Nola_Son is offline
Learning to use the forums
 
Join Date: Aug 2015
Posts: 3
Default Re: "Chattering" when accelerating, can't top 55mph

You say "under load," but I am not pulling anything and I live in la where the only uphill is an interstate overpass. Even when I turn and put it into 2nd, I am starting to hear it...
That link helps a lot. Thanks!

As for the leak, didn't know if anyone had a similar issue after chaning the pump. There is some rust in there from the previous owner that put only water in (my grandpa). So I know that's definitely a factor, too.
Reply With Quote
  #4  
Old 08-18-2015, 11:30 AM
mms1361 mms1361 is offline
Ford Ranger Driver
 
Join Date: Apr 2012
Posts: 624
Default Re: "Chattering" when accelerating, can't top 55mph

By under load i mean it involves anything that will cause your engine to work harder. Going uphill, towing things, giving it wide open throttle.

For example you have to work harder to climb up a set of stairs than just walking on a flat surface. Carrying a bear up the stairs would be even harder. Even running as fast as you can on a flat surface would exhaust you as well. The same logic applies to your truck. The only difference is it doesnt take a break when its under load so it results in higher combustion temperatures and pressures.

I thought you mentioned in your first post that the chattering was basically only occuring under load. Thats why i sort of pointed you towards pre-ignition.

But now youre saying the only uphill is on the overpass and you hear this chattering at low speeds. It could be possible its something mechanical thats broken or loose but if was that then the noise would likely occur at all times. Try filling your tank with premium and see if it makes a difference.

Also if you dont have motorcraft plugs get them.
__________________
'00 Ranger, supercab, flareside, 2wd, 3.0, auto, 3.73 open, Bilstein 4600s, 31x10.5x15 BFGs, 15x8 procomp 152s

Last edited by mms1361; 08-18-2015 at 11:34 AM.
Reply With Quote
  #5  
Old 08-18-2015, 11:41 AM
Nola_Son Nola_Son is offline
Learning to use the forums
 
Join Date: Aug 2015
Posts: 3
Default Re: "Chattering" when accelerating, can't top 55mph

Got it. I'll def try these things. In that link you sent me I saw there is a possibility the knock sensor could be damaged. Could be a real possibility as well.

----------

Also forgot to mention, I had a front and rear emissions flush done last week while I had the water pump replaced. The sound has only gotten noticeably worse since then...
Reply With Quote
Reply

Tags
chattering, ford, leak, ranger

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
"New to Me" Camper Top Dirt Devil Exterior Tech 6 12-17-2013 10:59 AM
For Sale: RDS Low profile Tool Box like new condition 62" Across Top 50 " Across Bottom kville boy Exterior Parts 0 07-07-2013 02:29 PM
my "over the top" Rockford Fosgate build, PICS!!! not a ford fan Audio / Video 14 05-19-2013 10:36 PM
"Soft Spot" at top of clutch pedal fenderam07 Drivetrain Tech 3 08-30-2011 03:42 AM
"Squelch" noise while accelerating? drewglenn04 4.0 SOHC / 4.0 OHV Tech 7 04-14-2010 04:41 AM