Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 06-05-2010, 12:01 AM
bordum128 bordum128 is offline
Like the Forums
 
Join Date: Jun 2010
Posts: 40
Default service recommendation?

Okay, i just bought an 01 xlt 3.0 v6. There have been 5 previous owners and lord knows how they took care of it. The truck has 112k and the engine was replaced 14 months ago and had 96k on it. So motor has about 100k. I want to start off fresh and give it a good serviceing. What should i do? The only problem with the truck is the check engine light is on with error code p0174 system too lean. Oh and when i look under the truck, there is no oil dripping from the oil pan or drain plug but it looks like there is a bit of oil on the bottom of the automatic transmission. like it looks like its coming from up top somewhere. There are no spots on my driveway! Thank you!
Reply With Quote
  #2  
Old 06-05-2010, 06:13 AM
STL STL is offline
...............

 
Join Date: May 2009
Posts: 23,398
Default Re: service recommendation?

I would do the following

Fuel Filter change
Oil and filter change
Transmission flush and filter change
Change rear/front differential front if it is 4wd
Spark Plugs and wires.
Change coil pack
Clean MAF
Air filter if dirty
Ball Joint Lubricate
Check Coolant and consider replacing
Brakes Inspect for wear and replace if needed
Cooling System check for leaks
__________________
2005 Edge


Last edited by STL; 06-05-2010 at 06:19 AM.
Reply With Quote
  #3  
Old 06-05-2010, 08:57 AM
bordum128 bordum128 is offline
Like the Forums
 
Join Date: Jun 2010
Posts: 40
Default Re: service recommendation?

Thank you! Maybe that's why Im getting that error code.
Reply With Quote
  #4  
Old 06-05-2010, 06:42 PM
modelageek modelageek is offline
Ford Ranger Driver
 
Join Date: Jan 2009
Posts: 6,257
Default Re: service recommendation?

Quote:
Originally Posted by bordum128 View Post
Thank you! Maybe that's why Im getting that error code.
if you are getting only that code and no others you probably have a vacuum leak on the drivers side head. look for a bad hose or crack in a hose etc on the drivers side of the engine
__________________
2004 Ext Cab, 4WD, 4.0, Auto, 154k. (4.0 engine is out of a 2009 Ranger w/96k) ( as of 7/1/2017)

2004 Ranger, Ext Cab, 2WD, 3.0, 5 speed , 4WABS, crank windows, no cruise, Edge 116k.(6/5,2014) (SOLD).
1999 Ford Ranger, Reg Cab, 2.5, 5 speed, 2WD, no AC, 150k (SOLD).
Reply With Quote
  #5  
Old 06-05-2010, 07:06 PM
bordum128 bordum128 is offline
Like the Forums
 
Join Date: Jun 2010
Posts: 40
Default Re: service recommendation?

Thank you very much sir! One more thing (Sorry im just learning how to work on my truck). Like I said, I have only had the truck for 3 days and so I decided to check the fluids. The oil looked great. The oild cap was clean. Thranny fluid was clean. HOWEVER, I noticed that the radiatior "overflow resivor" was bone dry. I then looked at the radiator and noticed that it was a bit low (I had to add about 3 cups of fluid to top it off). I cannot find any place where it has been leaking! Every once in a while, I can smell that "radiator fluid" smell, but I cant pinpoint it. The truck runs and idles smooth and does NOT over heat. Thank you! Oh, I let it run for like 5 min and I noticed that a small amount of water was dripping from under the truck from the exhaust (Right about the middle of the truck)
Reply With Quote
  #6  
Old 06-05-2010, 07:09 PM
STL STL is offline
...............

 
Join Date: May 2009
Posts: 23,398
Default Re: service recommendation?

Quote:
Originally Posted by bordum128 View Post
I then looked at the radiator and noticed that it was a bit low (I had to add about 3 cups of fluid to top it off). I cannot find any place where it has been leaking! Every once in a while, I can smell that "radiator fluid" smell, but I cant pinpoint it.
Is the passenger side foot area wet?

Quote:
Originally Posted by bordum128 View Post
I let it run for like 5 min and I noticed that a small amount of water was dripping from under the truck from the exhaust (Right about the middle of the truck)
Was the air running?
__________________
2005 Edge

Reply With Quote
  #7  
Old 06-05-2010, 07:22 PM
bordum128 bordum128 is offline
Like the Forums
 
Join Date: Jun 2010
Posts: 40
Default Re: service recommendation?

No water on the floor... and yes, the air conditioner was on. Thank you!
Reply With Quote
  #8  
Old 06-05-2010, 07:24 PM
STL STL is offline
...............

 
Join Date: May 2009
Posts: 23,398
Default Re: service recommendation?

Could have just been condensation from the air being on
__________________
2005 Edge

Reply With Quote
  #9  
Old 06-05-2010, 07:26 PM
bordum128 bordum128 is offline
Like the Forums
 
Join Date: Jun 2010
Posts: 40
Default Re: service recommendation?

Ok, I thought it was weird that it was coming from under the truck, from the exhaust, and just about under the bed. Thanks!
Reply With Quote
  #10  
Old 06-05-2010, 07:28 PM
STL STL is offline
...............

 
Join Date: May 2009
Posts: 23,398
Default Re: service recommendation?

Condensation from the ac wont be that far back. Usually it is about where the passenger feet would be in that general area.
__________________
2005 Edge

Reply With Quote
  #11  
Old 06-05-2010, 07:37 PM
bordum128 bordum128 is offline
Like the Forums
 
Join Date: Jun 2010
Posts: 40
Default Re: service recommendation?

Yeah, so Im not sure why the exhaust would have a small amount of water dripping from the middle of the pipe (Under the bed area)
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Anyone in the Emergency Service Field? whfd930 Off Topic 26 10-25-2011 11:07 AM
Good Tire Recommendation davidjsouth Wheels and Tires 39 06-29-2010 01:50 PM
50 thousand mile service time. greyghost 4-Cylinder Tech 13 11-21-2009 02:25 PM
Service manuals - where to buy ? RangerChad General Ford Ranger Discussion 8 09-11-2009 06:31 PM