Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 02-22-2015, 07:21 PM
NyteFire NyteFire is offline
Like the Forums
 
Join Date: Aug 2014
Posts: 49
Default Rough idle with new plugs/wires/coil pack/vacuum hoses

Like the title says:

Rough idle with new spark plugs, wires, a new coil pack, and new vacuum lines. The fuel filter is also new.

I'm at a loss where to go from there
__________________
2001 Ranger Edge
3.0L V6 automatic with 73k Miles
Reply With Quote
  #2  
Old 02-22-2015, 09:21 PM
Requesting flyby Requesting flyby is offline
Tower this is ghostrider
 
Join Date: Mar 2011
Posts: 210
Default Re: Rough idle with new plugs/wires/coil pack/vacuum hoses

Did you clean your MAF sensor? That's a common issue. Also check to see if the elbow in the PCV hose isn't ripped. They would cause a rough idle. The PCV might only be on the 4.0, I'm not sure. Just suggestions.
__________________
2001 XLT 2wd 4.0 DWB Supercab w/ ARE z series cap w/ rack, 4x4 grille, 4x4 bumper w/fogs, 2" Lift, 16" rims w/ Hankook Dynopro ATM tires, Hella Black Magics, Headlight Mod, Flowmaster 50, and more. 103,000 miles!!
Reply With Quote
  #3  
Old 02-22-2015, 11:09 PM
LilRanger93 LilRanger93 is offline
Go ahead, make my day
 
Join Date: Sep 2012
Posts: 1,841
Default Re: Rough idle with new plugs/wires/coil pack/vacuum hoses

Check and clean your idle air control valve. And you gotta remember, these 3.0 motors have a rough idle. Is the idle rougher than before?
__________________
93 Ranger XL 3.0 V6
-Tint, wheels, K&N filter, Flowmaster super 44.
04 Mustang GT Vert.
-Tons of mods, supercharged 392/393
Quote:
Originally Posted by stateranger View Post
If want real power you need to Plasti-Dip the entire engine including the valves and bearings, that's good for up to 150 horsepower.
Reply With Quote
  #4  
Old 02-23-2015, 06:17 AM
ebuc ebuc is offline
Learning to use the forums
 
Join Date: Feb 2015
Posts: 7
Smile Re: Rough idle with new plugs/wires/coil pack/vacuum hoses

Quote:
Originally Posted by LilRanger93 View Post
Check and clean your idle air control valve. And you gotta remember, these 3.0 motors have a rough idle. Is the idle rougher than before?
My newly purcahsed, 93, 3.0 stalled twice since Ive added 300 miles to a 161000K motor and seemed to me to have rought idle, so mechanic took off idle air control to clean but it was clean, but he suggests that is most likely that provide plugs, cap, wires rotor etc.....

I previously he states a new power pack, but mine has a cap so I assume a rotor.

My 97 Escort has power pack and I like not having cap and rotor.

His truck must be newer model 3.0..

ebuc
__________________
2/2015 $2000., 93 Ford Ranger, Ext. Cab, VE 3.0( Vulcan ) A4LD(?) Auto Trans.. 161000K(?), First job was in Pure/Union 76 serivce station, IL, much older now and do any and all Handy Man Jack of all trades type work.
Reply With Quote
  #5  
Old 02-23-2015, 10:45 AM
dwbailey89 dwbailey89 is offline
Learning to use the forums
 
Join Date: Feb 2015
Posts: 11
Default

Make sure the wires are on the right plugs. The wiring is backwards on the 3.0. Mine did the same thing after I put in a new coil pack, plugs and wires.
Reply With Quote
Reply

Tags
filter, fuel, idle, loss, rough, pack/vacuum, hoses

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Best brand of Coil Pack, Wires & Plugs for 3.0 ezeWolf1 3.0 Vulcan Tech 36 04-12-2015 12:50 AM
Changing plugs and wires. Coil pack too? LoJosRanger 4.0 SOHC / 4.0 OHV Tech 3 01-28-2015 08:06 AM
new plugs+wires+coil pack CAUSING Stalling thatranger General Tech 18 04-21-2013 06:46 PM
Spark plug wires and coil pack GAROUTTE78 3.0 Vulcan Tech 3 10-21-2011 08:57 AM
my 92 ford ranger 4.0l doesn't have spark, I have new coil pack, plugs and wires? Ruben H 4.0 SOHC / 4.0 OHV Tech 2 07-23-2009 12:16 AM