Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #16  
Old 07-20-2014, 07:24 AM
RangerNovice1 RangerNovice1 is offline
Learning to use the forums
 
Join Date: Jul 2014
Posts: 4
Default Re: 3.0 flashing check engine light and misfire on #6... HELP!

I'm new here, but I can share my experiences with you. First, there is a TSB from Ford on at least the 04-06 3.0 Engines on the exact problems you are experiencing.

They are referencing "recessed exhaust valves" and suggest replacing both heads. I did that about 6 wks ago, and about 3 weeks ago my engine basically died. It developed several oil leaks...not sure whether that was due to old gaskets and better compression after the new heads were put on or what.

Anyhow, I have 135K on my vehicle and the same problems you have described occurred on my truck in various forms since about 75K. It started as what I would call an irregular idle, then developed into an occasional flashing check engine light, which became more and more prominent. After that, it started almost stalling out at lights, then when pressing the gas pedal almost zero acceleration for about 5 seconds. Then it would kick in and drive relatively normally.

Long story short, I had a new coil pack put in, new plugs, wires, throttle body cleaned out, ...I could go on, but nothing helped. Eventually the compression dropped in cylinders 4&6...which was the beginning of the end.

The kicker is that after the new heads failed, being a glutton for punishment, I just had a used 3.0 installed yesterday. The new engine runs well, doesn't smoke, etc.,....but has the same unusual idle. Now I'm almost convinced that this whole scenario is either an issue with the ECU or with the cats.....I'm really confused and looking for answers.

One final comment, which I'm sure is not related, but interested nonetheless.....I always thought I had a 12 gallon fuel tank because it wouldn't accept more than 13 total gallons, and I've owned the truck for 4 years. My gas guage hasn't worked in that time period, nor has the low fuel warning light. When I got my truck back yesterday after the used engine install, the fuel guage now functions, as does the low fuel warning light. What's more perplexing is that when I filled up at the pump, it now takes a full 16 gallons?????? ....and I haven't done any drugs since the 80's....

I hope you find your answers......all I can give you is my experience with nearly the exact same issue.

-Craig
__________________
2004 Ford Ranger
Mainly just my work truck
Not Really an Enthusiast...at least yet
...More Details Later
Reply With Quote
  #17  
Old 07-20-2014, 10:51 AM
GLH GLH is offline
Ford Ranger Driver
 
Join Date: Oct 2011
Posts: 8,818
Default

I have never seen any 3.0 vulcan that had a smooth idle.
Reply With Quote
  #18  
Old 08-13-2014, 08:36 AM
rig510 rig510 is offline
Learning to use the forums
 
Join Date: Aug 2014
Posts: 2
Default Re: 3.0 flashing check engine light and misfire on #6... HELP!

Any updates? Having the exact same problems with my truck. Took it to my mechanic..yeah..the cylinder heads need to be replaced. Weary about replacing them if that isn't what's causing the issue.
Reply With Quote
  #19  
Old 08-14-2014, 01:41 AM
RangerNovice1 RangerNovice1 is offline
Learning to use the forums
 
Join Date: Jul 2014
Posts: 4
Default Re: 3.0 flashing check engine light and misfire on #6... HELP!

...Rig510..I hope I'm not stealing the original thread, but I posted above the difficulties I've had.

Just to give an update on my situation, I now have about 2K on a used engine that I installed after my last one died. While it hasn't thrown any codes yet, nor a check engine light, it still has an annoying idle that feels like it wants to cut out, but never does.(it's sporadic at this point, which is how my original engine's issue first started out)

I THINK it seems to be worse during warmer afternoon weather here in GA, but, at this point, it may be my imagination. Two weeks ago, I took off both the MAF sensor and the Idle Air Flow sensor and cleaned them both with MAF cleaner. The IAF sensor was filthy, and I thought I was onto something, but it made no difference.

In summary, from a troubleshooting perspective, due to the fact that I put in a "used" engine, I can't honestly say that I completely eliminated that as a variable for the issues that I have. It's possible that this engine, being a 3.0 suffers from the same as the original. However, obviously, many of the same parts from the old system are still being used, so I am very suspicious that something else is at work. I had a mechanic actually put a computer on this thing and everything check out as engine is firing fine....all systems normal.

Final thoughts....still confused and frustrated..... about the only thing I haven't eliminated is something strange in the gas tank(haven't looked in it yet), some component having faulty wiring or ground, or possibly the 85 catalytic converters and mufflers this thing has which is possibly choking the engine. Everyone I talk to says the cats aren't the issue as that would throw a code, and I even took it to a muffler shop where the guy drilled a hole in front and in back of the second cat, and used a guage to check the back pressure and he said it was fine.

Maybe the ECU is bad????...sorry, no real help here, but I thought I'd give you more of my saga.... the worse part is that it runs like a champ on the hwy...and even though it feels like it wants to die while sitting, the rpm's consistently stay around 800 at idle.

...this is my work truck,...otherwise I would have already bought a Honda....
__________________
2004 Ford Ranger
Mainly just my work truck
Not Really an Enthusiast...at least yet
...More Details Later
Reply With Quote
  #20  
Old 08-14-2014, 02:49 AM
GLH GLH is offline
Ford Ranger Driver
 
Join Date: Oct 2011
Posts: 8,818
Default

Sorry, I know y'all don't like to hear this, but it sounds completely normal to me, for these engines.
Reply With Quote
Reply

Tags
3.0, check engine, misfire, misfire #6, rough idle

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
check engine light flashing ajw1275 3.0 Vulcan Tech 8 09-06-2012 09:17 AM
Check Engine Light Flashing Codes Help (VIDEO)?? ZohanisBack 4-Cylinder Tech 2 11-17-2011 05:56 AM
Check engine light on and flashing once in awhile matheny00 3.0 Vulcan Tech 5 09-19-2011 01:14 PM
please help! flashing check engine light hrk003 4-Cylinder Tech 8 09-03-2011 06:26 PM
Flashing Check Engine Light Craig Novacek Exterior Tech 13 02-08-2011 07:56 AM