Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 03-05-2014, 08:51 AM
techturner22 techturner22 is offline
Ford Truck Driver
 
Join Date: Feb 2014
Posts: 77
Default Big problem ):

So about a month ago, I noticed ol' girl was running hot. I stopped at a gas station, put some coolant in it after she cooled down, continued on my way, and temp ran normal the rest of the night and for another two weeks or so. About a week later, I was driving up the interstate and I had my cruise on, suddenly the heat stopped blowing hot and it was ICE COLD. Recently, she's been running pretty hot (close to redlining) and heat has been only hot when the RPMS are higher. So I checked all the lines in the radiator. All good. But when I was checking them, I noticed a substantial amount of coolant on the ground. Turns out my radiator cap is leaking and it seems to be leaking elsewhere too. I'm thinking a head gasket/heater core issue? But I'm weary to replace the head gaskets and still have the problem because that's not an easy and cheap fix. Recently replaced serpentine belt and idler pulley. Any thoughts?
__________________
1997 Ranger XLT Single Cab 3.0L 2WD
-Straight Pipe Cat Back, Future 302 or 4bt swap, 2006 Mirrors, 1992 Wheels, 6000K HIDs, Color Match Toolbox-
Reply With Quote
  #2  
Old 03-05-2014, 08:53 AM
djfllmn djfllmn is offline
ford dealer parts guy
 
Join Date: Apr 2011
Posts: 20,770
Send a message via AIM to djfllmn
Default

I'm gonna go out on a limb here and check the water pump first
__________________
2016 F150 Supercrew XLT 5.0
1968 Ford Thunderbird Tudor 429 Thunderjet V8

(Click for Project Log)

traded-2007 F150 XLT Supercab 5.4
Sold:03 Sonic Blue FX4 Steppie 4.0SOHC 5spd
ranger free since 6/15/2012

Quote:
Originally Posted by Logan03CO View Post
These threads make me feel better about myself....
Quote:
Originally Posted by guell View Post
Welcome to the internet, if this is your first visit to it I suggest you stock up on a lot of preparation h cause you gonna be butt hurt a lot
Reply With Quote
  #3  
Old 03-05-2014, 09:04 AM
rangerlocal rangerlocal is offline
Ermahgerd Ferd Rernjurs!
 
Join Date: Aug 2012
Posts: 1,938
Default Re: Big problem ):

Make sure you don't have a collapsed hose. If your coolant looks rusty, be sure to check that pump. Pull the cap off the radiator while the truck is running and look for circulating coolant. If it's not moving, the pump impellers may be gone.
__________________
2000 Ranger XL, 2WD, 3.0l, 3.73 rear, 10" rear drum ABS, standard cab, long bed, A/C, 4r44e auto trans w/transgo shift kit, throttle cable mod, air box silencer mod, rear sway bar retrofit, white grill swap, CURT hitch, Westin step bars
Quote:
Originally Posted by writtenaudio View Post
Man wish i had tits, seems like its easier to get a job if you have tits.
Reply With Quote
  #4  
Old 03-05-2014, 09:55 AM
modelageek modelageek is offline
Ford Ranger Driver
 
Join Date: Jan 2009
Posts: 6,257
Default

Quote:
Originally Posted by rangerlocal View Post
Make sure you don't have a collapsed hose. If your coolant looks rusty, be sure to check that pump. Pull the cap off the radiator while the truck is running and look for circulating coolant. If it's not moving, the pump impellers may be gone.
I agree with dj and rangerlocal . Could be the water pump. I would stop driving. The 3.0 heads do not like to over heat. They will fail.

This is what i would do.

-do a combustion test to eliminate head gasket.

-investigate and find the leak. Repair as needed. No matter what install a new motorcraft tstat.
__________________
2004 Ext Cab, 4WD, 4.0, Auto, 154k. (4.0 engine is out of a 2009 Ranger w/96k) ( as of 7/1/2017)

2004 Ranger, Ext Cab, 2WD, 3.0, 5 speed , 4WABS, crank windows, no cruise, Edge 116k.(6/5,2014) (SOLD).
1999 Ford Ranger, Reg Cab, 2.5, 5 speed, 2WD, no AC, 150k (SOLD).
Reply With Quote
Reply

Tags
3.0, leak, overheat, radiator

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
I have a big problem 94xltrangerdanger 4.0 SOHC / 4.0 OHV Tech 15 04-08-2013 01:47 PM
Big Problem Little Truck please help!!!! Tyler54c5u 3.0 Vulcan Tech 16 03-05-2012 02:17 PM
I have a problem........ A big one.... Marine513 Drivetrain Tech 0 10-13-2011 06:30 AM
Big problem! MikeLoco Electrical Tech 3 06-04-2011 09:57 AM
Big problem! smakes 4-Cylinder Tech 10 01-28-2010 07:00 PM