Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > Engine Tech Forum > 6-Cylinder Tech > 3.0 Vulcan Tech
Forgot Password? Join Us!


Reply
 
LinkBack Thread Tools Search this Thread

  #1  
Old 04-05-2010, 02:28 PM
Learning to use the forums
 
Join Date: Apr 2010
Posts: 12
Default Major diag problems and need help!

OK guys here is what I got. 2003 Ford Ranger, 3.0L V6. The g/f was drving the truck home and it was barely running. Rough idle and rough driving. Could not get over 60 mph on the interstate. Last night I pulled the following codes:
P0171, P0175, P0300, P0304, P0305, P0306 & P0316. After I pulled the codes I cleared them. Today I went to work on it and let the engine idle. Still rough might I say. CEL came on and I got these two codes I have gotten before yesterday. P0304 and P0316.

Here is what I tested. I sprayed starter fluid all over the place and got nothing for a vacuum leak. I did and ohm test on the fuel injectors on cylinder 1, 2,3 & 4. Could not get to 5 or 6. They tested within spec. I also listened to hear the tick of the injectors while running and they tick with no problems. I did a resistance test on the coil packs and they were within spec as well. Primary and secondary. I checked the resistance on the plug wires and they were good as well. Pulled the plugs and they were good as well. The reason I say this on the plugs and wires is I replaced them last summer. I also did a fuel system pressure check at the schrader valve and it was running 62PSI with no fluctuations.

I am pretty much at a loss here. I have not ran a compression check yet cause I am finding it hard to believe that be the problem. The g/f has taken pretty good care in making sure the oil is changed and not running the crap out of it.

I really could use some help here. If anyone has any ideas or have ran into these same problems let me know. Thanks!

Last edited by csharp100; 04-05-2010 at 02:38 PM.
Reply With Quote
  #2  
Old 04-05-2010, 07:51 PM
Tank Diver
 
Join Date: Mar 2010
Posts: 3,056
Default Re: Major diag problems and need help!

This might help you out some. The P03XX codes seem to be related to the P017X codes.

http://autorepair.about.com/library/...bl406a-lib.htm
__________________
Sgtsandman's Work in Progress
2011 Ranger XLT, 4X4, 4 door Super Cab. 4.0L, 5 Speed M50D-R1HD, 3.73:1, 8.8" open differential, Jason Pace cap
1999 Honda CR-V EX, RT4WD, 2.0L, 5 Speed MT, 4.56:1, open differential
Reply With Quote
  #3  
Old 04-05-2010, 10:44 PM
Ford Ranger Owner
 
Join Date: Apr 2010
Posts: 66
Default Re: Major diag problems and need help!

check to make sure your egr valve didn't rust and pup up like mine did a while back... its on the driver side of the motor neat the oil dip stick... its mounted to a cast iron looking rail.. the piece almost looks like a dsm blow off valve.. mine rusted and the spring in it made the top pop up... pushed it back down and the truck ran fine.. had it replaced a few days later.
Reply With Quote
  #4  
Old 04-06-2010, 06:16 AM
Learning to use the forums
 
Join Date: Apr 2010
Posts: 12
Default Re: Major diag problems and need help!

No EGR on this particular vehicle. I am going to try the CPS. It is not whining but I happen to have the feeling that is what it is. Over 200K miles and I am surprised it has not gone out. I was talking to a friend and the CPS could still be going out without sending a code. I cannot figure out what else it would be. Still looking for suggestions if anyone has ran into this.
Reply With Quote
  #5  
Old 04-06-2010, 09:10 AM
Ford Ranger Owner
 
Join Date: Apr 2010
Posts: 66
Default Re: Major diag problems and need help!

oh sorry my bad lol.. Im really good with audio... not so hot on engine do dads
Reply With Quote
  #6  
Old 04-06-2010, 02:55 PM
Learning to use the forums
 
Join Date: Apr 2010
Posts: 12
Default Re: Major diag problems and need help!

Ok well i changed the CPS, (camshaft position sensor) and the idle smoothed out. Changed the oil and the antifreeze. Had a thermostat problem and fixed that. Took it out on a highway test run and still lacks power. CEL flashed on me and continued to flash. Not a steady state. I got home and pulled a P0304 code. I now have two choices that I see. Replace the fuel injector in cylinder 4 which I am going to do and see if that works. My other choice is the cat. Can anyone HELP me on this? Am I even getting close?
Reply With Quote
  #7  
Old 04-06-2010, 04:36 PM
Ford Tough
 
Join Date: Mar 2009
Posts: 288
Default Re: Major diag problems and need help!

What scan tool do you have? If you have a higher end one you can look at injector pulses and see if #4 is firing. You may have an issue with the one bank because you had misfires on 4-6 cylinders. I wouldn't touch the cats because you obviously have engine troubles. You could do a compression test on just #4 to see if thats still good. Another trick is to get some salt water in a spray bottle and squirt it on the spark plug wires. One of the wires could have a pinhole in it so it is arcing to something close to the hole. Once you spray the water on it, the arc will actually be able to be seen.
__________________
1996 Ford Ranger STX 4x4 4.0L
1983 Honda Shadow VT750C
Reply With Quote
  #8  
Old 04-06-2010, 06:47 PM
Learning to use the forums
 
Join Date: Apr 2010
Posts: 12
Default Re: Major diag problems and need help!

Quote:
Originally Posted by West View Post
What scan tool do you have? If you have a higher end one you can look at injector pulses and see if #4 is firing. You may have an issue with the one bank because you had misfires on 4-6 cylinders. I wouldn't touch the cats because you obviously have engine troubles. You could do a compression test on just #4 to see if thats still good. Another trick is to get some salt water in a spray bottle and squirt it on the spark plug wires. One of the wires could have a pinhole in it so it is arcing to something close to the hole. Once you spray the water on it, the arc will actually be able to be seen.
The scan tool I have only pulls the codes. I will try the compression test sometime tomorrow. The salt water I never thought of. Like I mention in my original post. The wires were replaced last summer and are in their respective looms. I thought about moving the injector but it is under the intake manifold. So my thought was to replace the thing since I have to remove the manifold and get a new gasket anyways. The truck does have 208K miles on it.
Reply With Quote
  #9  
Old 04-12-2010, 04:02 PM
Learning to use the forums
 
Join Date: Apr 2010
Posts: 12
Default Re: Major diag problems and need help!

Did a compression check and cylinder 4 was way down. Removed the head and saw a bad head gasket. In the midst of replacing it. We will find out tomorrow.
Reply With Quote
  #10  
Old 04-12-2010, 05:55 PM
Ford Ranger Driver
 
Join Date: Jan 2010
Posts: 828
Default Re: Major diag problems and need help!

I just went thru this, check out my thread...
#20 ... I had to buy it...lol
__________________
22 and counting...
Reply With Quote
  #11  
Old 05-03-2010, 07:16 AM
Learning to use the forums
 
Join Date: Apr 2010
Posts: 12
Default Re: Major diag problems and need help!

Ok, replaced both heads, checked compression and all are within 175 to 165, changed crank position sensor and still pull codes P0300, P0301, P0304, P0305, & P0316. I am at my wits end. I tested the coil pack and the primaries and secondaries and well within specs. Has anyone ran into this?
Reply With Quote
  #12  
Old 12-17-2010, 03:15 PM
ShadeTreeMech
 
Join Date: Nov 2010
Posts: 13
Default Re: Major diag problems and need help!

Did you ever find out what the cause of the problem and all of the codes was? My nephew's wife's truck is setting the P0300, P0301 and P0316 codes and also shudders or bucks at highway speeds if you gently tip into the throttle while cruising. Curious to know what you found and how you solved the problem.
Reply With Quote
  #13  
Old 12-19-2010, 07:01 PM
Ford Motor Company
 
Join Date: Sep 2010
Posts: 126
Default Re: Major diag problems and need help!

looks to be a cylinder 1 misfire at least once within the first 1000 revolutions, try replacing the #1 plug, wire, and coil slot
__________________
2000;3.0 vulcan;flowtech raptor muffler; no cats;k&n oil filter;goodyear wrangler tires;spectre cold air intake;200 watt pioneer headunit with 2 kenwood jl-80 boxes holding 2 10 inch pyle subs, 2 kenwood 4x6 2ways and 2 polkaudio 4x6 plates and two xplod 3 ways in the doors;plenty of scratches dings and dents, chipped (flashpaq)
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Major problem cwc ranger General Tech 0 03-09-2010 07:31 AM
Major sugery whippersnapper02 General Ford Ranger Discussion 65 03-05-2010 11:57 PM
problems IVAN General Ford Ranger Discussion 1 02-17-2010 06:40 PM
Major surgery Mike Vehicle Snapshots 16 01-12-2010 04:59 PM
3.0 major running problems bvallerand 3.0 Vulcan Tech 2 06-26-2009 07:56 PM



Search Engine Friendly URLs by vBSEO 3.6.0 ©2011, Crawlability, Inc.