Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Thread Tools Search this Thread

Old 04-02-2010, 08:12 PM
uajosh uajosh is offline
Amstaff Ranger
Join Date: Feb 2010
Posts: 237
Cool Speed Sensor Symptoms

The spedometer stays on 0 until around 15 mph.
The ABS light is on!
The Check Engine light is on.
It jumps when shifting into 2nd gear.
It would almost do dead when the brakes were pressed once up to speed.

Just a little info for all yall people. It also cost $135.00 to fix it at the shop. Don't know how much the actual part was. At the time of my speed sensor going out I had my other two cars in the shop already. That's just the luck I have.

2000 Ford Ranger Stepside XLT 2wd 3.0 V6 Flex
*Magnaflow Exhaust
*Accell Performance Spark Plug Wires.
*E3 Performance Spark Plugs.
*K&N Cold Air intake
*HID Conversion Kit
*K&N Air Filter

Card The Yard
We Offer Lawn Greetings for All Occasions!
Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar Threads
Thread Thread Starter Forum Replies Last Post
Speed! ~Fast*Life~ 4.0 SOHC / 4.0 OHV Tech 55 07-04-2012 09:40 AM
Coolant temp sensor vs temp sensor JeremyC 4-Cylinder Tech 1 02-06-2010 05:11 PM
Want to Buy: 87 2.3 5 speed bellhousing holdenrichard Engine & Drivetrain Parts 3 02-03-2010 09:36 AM
speed issue chris3182 General Tech 1 11-02-2009 06:40 PM
5 to 6 speed??? infamoustiggr 4-Cylinder Tech 4 07-17-2009 11:57 PM