Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #31  
Old 04-24-2014, 03:38 PM
Cole_CT Cole_CT is offline
Ford Motor Co
 
Join Date: Jan 2014
Posts: 173
Default Re: High Idle problems

Quote:
Originally Posted by rang-a-stang View Post
thank you for the responses Clinton64xl and Cole_CT


Will do (vaccum leaks). Air filter has about 1,000 miles on it. The throttle body was cleaned when i did the IAC replacement (about 800 miles ago).

Personally, i am not a huge fan of spraying very flamable chemicals around a running/warm engine. Usually to find vaccum leaks, i will unhook a a line, apply vaccum with a hand pump/guage and verify it holds. it presents a little less of a fire hazard and can be done when the engine is cold. I'll probably pull the upper/lower intakes and replace their gaskets just to be sure. The gaskets are cheap and my labor is free. it will also give me the chance to port match them.

I also saw on another forum last night, a guy had very similiar issues to me and found significant damage to the computer/harness connector. I will be checking that tonight, too.
You could also use a smoke machine to check for vacuum leaks.
__________________
- 2002 XLT Ext. Cab - 4.0L - FX4 - 4.10 LS - 31x10.5x15 GW A/T on Alcoas - Kenwood HU - Memphis Sub - Rockford Amp -
- Custom Whelen Reciever Light - Weatherguard Toolbox -
My Build Thread
Reply With Quote
  #32  
Old 04-28-2014, 11:13 AM
rang-a-stang rang-a-stang is offline
Learning to use the forums
 
Join Date: Apr 2014
Posts: 5
Default Re: High Idle problems

This weekend I replaced my lower intake manifold gaskets, valve cover gaskets, and did a bunch of cleaning. My lower intake gasket looked like it was going around cylinder #5. I am not sure if that was my problem but it was a problem. I replaced all the O-rings on the fuel injectors too. I noticed alot more oil on all my passages than normal so I will replace the PCV valve as I reassemble.

As i am putting the engine back together I am checking each sensor and vacuum line. So far I have found both my Coolant Temp Sender is bad (open, explains why my Temp Guages didn't work) and my Coolant Temp Sensor is bad (also open which may explain a high idle when warm). I fixed 2 oil leaks too. Tonight I plan to start putting the upper intake and all it's sensors and vacuum lines back on. My stomach and chest are like ground beef from laying across the hook latch to get that !@#$^%& passenger side rear valvle cover bolt off/on.
Reply With Quote
  #33  
Old 04-29-2014, 08:40 PM
JJSLAIL22 JJSLAIL22 is offline
Ford Ranger Driver
 
Join Date: Jun 2013
Posts: 1,358
Default Re: High Idle problems

Quote:
Originally Posted by rang-a-stang View Post
This weekend I replaced my lower intake manifold gaskets, valve cover gaskets, and did a bunch of cleaning. My lower intake gasket looked like it was going around cylinder #5. I am not sure if that was my problem but it was a problem. I replaced all the O-rings on the fuel injectors too. I noticed alot more oil on all my passages than normal so I will replace the PCV valve as I reassemble.

As i am putting the engine back together I am checking each sensor and vacuum line. So far I have found both my Coolant Temp Sender is bad (open, explains why my Temp Guages didn't work) and my Coolant Temp Sensor is bad (also open which may explain a high idle when warm). I fixed 2 oil leaks too. Tonight I plan to start putting the upper intake and all it's sensors and vacuum lines back on. My stomach and chest are like ground beef from laying across the hook latch to get that !@#$^%& passenger side rear valvle cover bolt off/on.
Let us know how it runs after....
__________________
2000 Ford Ranger XLT - 4x4 Off Road - 3.0L - 5speed - 4.10 - 3in BL - 2in Torsion Lift - Lokka Front Locker - RCI Skids - Rancho Shocks - Super Start Extreme AGM Deep Cycle Battery - Stock 15x7 Rims - 33x10.50 BFG M/T KM2 w/ Hitch Mounted Spare - Smittybilt XRC8 Winch - On Board Compressor - Hidden Snorkel
Reply With Quote
  #34  
Old 04-30-2014, 11:03 AM
rang-a-stang rang-a-stang is offline
Learning to use the forums
 
Join Date: Apr 2014
Posts: 5
Default Re: High Idle problems

Last night I had to reinstall the #3 cyl intake rocker and pushrod. I'm not quite sure why Ford made it so you have to remove that pushrod to remove the lower intake but I digress.

I got the lower all buttoned up, checked all my vacuum lines, checked the ACT sensor, TPS, and reinstalled upper intake. I added new coolant and cranked 'er over. Nothing. grabbed my timing light, Awesome 180 out. So i had the joy of re-installing the Distrobutor. Cranked it over and I got a couple pops but no running. CHecked my timeining and i was still 20 After TDC. Tried to time it but could not get it to go any farther back than TDC. So i grabbed a mirror and pulled the distributor cap off. I could see a lower intake manifold bolt was interfereing with the bottom of the distributor so i pulled it out, ground the distributor a little and reinstalled it. Now it starts but it was too later for me to finish timing it and going for a test drive. With timing at TDC it sure seems to idle better so far.

So the only real vacuum leak I found was for the circuit that connects to the back of the air filter housing. What is that? I just plugged it for now...
Reply With Quote
  #35  
Old 05-02-2014, 12:45 PM
rang-a-stang rang-a-stang is offline
Learning to use the forums
 
Join Date: Apr 2014
Posts: 5
Default Re: High Idle problems

It took me FOREVER to get this Biatch timed. Every distributor i have ever installed could go in one way. This one goes in 4 ways which means it can be 90 degrees out, 180, or 270. I was going CRAZY trying to get it to run right.

Anywho, i got it started and it ran AWESOME. Like SUPER AWESOME. I was SOOO stoked. Smooth as glass, idles correctly, lots of power. So stoked. Then i pulled it in the garage and it pissed coolant all over my clean floors. I looked up and saw coolant spewing out of the water pump weep hole. Thats pretty awesome. Luckily it was only 15 bucks and in stock for a new water pump. About 75 miles on it now and its running super dee duper.
Reply With Quote
  #36  
Old 05-07-2014, 11:26 AM
Capt. Ford Capt. Ford is offline
Learning to use the forums
 
Join Date: Apr 2014
Posts: 1
Default Re: High Idle problems

high idle in freeway! I have 2500 rpm @ 65mph but my morning start is good 800-900rpm is this normal? My friend said too high, should be just 2000 or 1900 @ 65mph. Thanks
Reply With Quote
  #37  
Old 05-07-2014, 11:46 AM
CFH665 CFH665 is offline
Ford Tough
 
Join Date: Mar 2013
Posts: 226
Default

Miy 4.0 with 3.73 gears idles around 2500rpm doing 70
Reply With Quote
  #38  
Old 05-07-2014, 08:53 PM
GLH GLH is offline
Ford Ranger Driver
 
Join Date: Oct 2011
Posts: 8,818
Default

What the heck is wrong with you people ? Nothing is idling while going down the freeway ! Idling is the engine speed while sitting still and not on the accelerator !
Reply With Quote
  #39  
Old 05-08-2014, 06:44 AM
JJSLAIL22 JJSLAIL22 is offline
Ford Ranger Driver
 
Join Date: Jun 2013
Posts: 1,358
Default Re: High Idle problems

Quote:
Originally Posted by GLH View Post
What the heck is wrong with you people ? Nothing is idling while going down the freeway ! Idling is the engine speed while sitting still and not on the accelerator !
I do understand and agree with your comment....to a point. However, your engine can be at idle doing 70, clutch in or in neutral. There's technically no load on the motor at that point. Therefor, it would idle. If you have a bad IAC, the speed would force induction of air past that valve, could bump you idle up a little...
__________________
2000 Ford Ranger XLT - 4x4 Off Road - 3.0L - 5speed - 4.10 - 3in BL - 2in Torsion Lift - Lokka Front Locker - RCI Skids - Rancho Shocks - Super Start Extreme AGM Deep Cycle Battery - Stock 15x7 Rims - 33x10.50 BFG M/T KM2 w/ Hitch Mounted Spare - Smittybilt XRC8 Winch - On Board Compressor - Hidden Snorkel
Reply With Quote
  #40  
Old 05-08-2014, 08:23 AM
GLH GLH is offline
Ford Ranger Driver
 
Join Date: Oct 2011
Posts: 8,818
Default

That's called coasting, and yes, and how is that relevant ?
Reply With Quote
  #41  
Old 06-07-2016, 06:30 AM
Wealthychap Wealthychap is offline
Learning to use the forums
 
Join Date: Jun 2016
Posts: 1
Default Re: High Idle problems

Check temp sensor /sender
Reply With Quote
  #42  
Old 07-29-2016, 01:15 PM
strikeingracerx strikeingracerx is offline
Learning to use the forums
 
Join Date: Jun 2016
Posts: 2
Default

05 Ford Ranger code said replace coil pack and I did I still have the same problem this truck was a wreck so it's possible there's a ground issues but I've looked over them very good very well I'm sorry anybody have a similar issues it's runs fine one day and next day it won't always misses at an idle then don't hesitate
Reply With Quote
  #43  
Old 07-29-2016, 01:28 PM
modelageek modelageek is offline
Ford Ranger Driver
 
Join Date: Jan 2009
Posts: 6,169
Default Re: High Idle problems

Quote:
Originally Posted by strikeingracerx View Post
05 Ford Ranger code said replace coil pack and I did I still have the same problem this truck was a wreck so it's possible there's a ground issues but I've looked over them very good very well I'm sorry anybody have a similar issues it's runs fine one day and next day it won't always misses at an idle then don't hesitate
Post the actual code #

"Losers focus on winners, winners focus on winning" TB12
__________________
2004 Ext Cab, 4WD, 4.0, Auto, 146k. (4.0 engine is out of a 2009 Ranger w/96k) ( as of 3/10/2016)

2004 Ranger, Ext Cab, 2WD, 3.0, 5 speed , 4WABS, crank windows, no cruise, Edge 116k.(6/5,2014) (SOLD).
1999 Ford Ranger, Reg Cab, 2.5, 5 speed, 2WD, no AC, 150k (SOLD).
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
89 2.9l high hydrocarbons and rough high idle dherndon99 2.9 Liter Tech 7 11-17-2010 06:50 AM
HELP! Rough idle/high rpms when stopping Scott 4-Cylinder Tech 11 08-20-2010 05:04 PM
2.3 high idle bob_rhoades78 4-Cylinder Tech 0 03-23-2010 07:31 PM
High idle in park!!!! POS1984ranger 2.9 Liter Tech 16 12-25-2009 07:48 PM
High idle & running rich RandSand 4.0 SOHC / 4.0 OHV Tech 2 10-08-2009 12:18 PM