Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #16  
Old 04-26-2012, 05:41 AM
The3pointslow The3pointslow is offline
wakawakawaka
 
Join Date: Jan 2012
Posts: 141
Default Re: High Idle problems

Yeah I have the same problem with my 99 5 speed. When I start it while it's warm out it will idle nicely at 1,000 rpm. The moment i blip the gas it will go to 1500 and stay there. I found out the only way to get the idle down is when I "bog" down the engine with my clutch for a second
__________________
1999 4x4 xlt 3.0 v6
5 speed manual
-------------------------

I think you've mistaken "Mustang" with "Ranger". She ain't gonna go too fast no matter what..
Reply With Quote
  #17  
Old 04-27-2012, 06:59 AM
Moobob1220 Moobob1220 is offline
Liking the Ford Ranger Forum
 
Join Date: Nov 2011
Posts: 29
Default Re: High Idle problems

I took mine to ford and they said that I need a kit for the high idle I've looked it up on the web site it's 38 $ people at parts say its 150 plus the charge for a new iac valve and all the stuff they said I needed came out to being twice what I payed for the truck
Reply With Quote
  #18  
Old 04-27-2012, 07:12 AM
The3pointslow The3pointslow is offline
wakawakawaka
 
Join Date: Jan 2012
Posts: 141
Default Re: High Idle problems

150 for IAC valve?!?!?! you got ripped off royally, it's so easy to change by yourself also
__________________
1999 4x4 xlt 3.0 v6
5 speed manual
-------------------------

I think you've mistaken "Mustang" with "Ranger". She ain't gonna go too fast no matter what..
Reply With Quote
  #19  
Old 04-27-2012, 10:24 AM
Moobob1220 Moobob1220 is offline
Liking the Ford Ranger Forum
 
Join Date: Nov 2011
Posts: 29
Default Re: High Idle problems

No th valve is 40 at autozone and is held on with two bolts the 150 is the high idle kit that that might fix my high idle I think it's a new plug the goes into the tps if I could see said kit I could more than likely make it but I've looked and found nothing from what they told me at ford something getting to much voltage witch in thorey could be fixed with a inducer or a restior
Reply With Quote
  #20  
Old 04-27-2012, 12:50 PM
Johnnypete201 Johnnypete201 is offline
Liking the Ford Ranger Forum
 
Join Date: Feb 2012
Posts: 29
Default Re: High Idle problems

Clean your egr valve and replace your dpfe sensor. Get the 30 dollar standard parts one from rock auto. took 2 days for it to ship to me with the 6 dollar shipping, and it works fine.

Cleaning my egr valve made my idle problem go away 90%

sparks/wires/air filter/maf/throttle/ are all free/cheap fixes you can do that are worth doing, new sparks/wires will help with mpg aswell.
Reply With Quote
  #21  
Old 05-26-2012, 11:39 AM
Moobob1220 Moobob1220 is offline
Liking the Ford Ranger Forum
 
Join Date: Nov 2011
Posts: 29
Default

It was the AIC valve the first one put on either wasn't the right on or was messed up when I bought it I put a new one on and it worked just like a new truck
Reply With Quote
  #22  
Old 05-26-2012, 05:24 PM
michael mcallister michael mcallister is offline
Ford Rangers
 
Join Date: May 2012
Posts: 207
Default

Sweet man this totally helps out a lot... I've had this problem before and I cleaned my whole intake system did a throttle body clean and checked all my hoses for intake leaks... It worked for 4000 miles until it started today after I shut my AC off...

Again I have no codes reading on my scan tool.

I'm glad to hear you got the problem fixed on your truck I hope it's the same for mine
Reply With Quote
  #23  
Old 05-31-2012, 09:13 AM
vicsantana91 vicsantana91 is offline
Liking the Ford Ranger Forum
 
Join Date: May 2011
Posts: 23
Default Re: High Idle problems

Same happens to me. When I change gears it accelerates by itself. Yesterday I was doing 25 mph in 2nd gear without using the accelerator. What could it be?
__________________
'94 Mazda B3000 v6 3.0lts
HID Bixenon 6000k/Pilot foglights/Spot lights w/100w Hella h3 bulbs/Custom ICE system/Gauge cluster LED conversion/LED interior lights/Thrust cable mod/Smoked tail lights
Reply With Quote
  #24  
Old 06-01-2012, 08:37 PM
my ranger my ranger is offline
PERRANGER
 
Join Date: Aug 2011
Posts: 112
Default Re: High Idle problems

have the same proble, change iac valve an dpfe sensor and still the problem
__________________
2002 ranger edge, 3.0 auto trans, some modes to come
Reply With Quote
  #25  
Old 06-09-2012, 06:03 PM
Moobob1220 Moobob1220 is offline
Liking the Ford Ranger Forum
 
Join Date: Nov 2011
Posts: 29
Default

Well I was wrong it's my egr valve and when I have the money I get it fixed and it will be good as new
Reply With Quote
  #26  
Old 05-14-2013, 08:00 AM
commanchero07 commanchero07 is offline
Learning to use the forums
 
Join Date: May 2013
Posts: 1
Post Re: High Idle problems

I have a 2000 Ford Ranger 4x4. I had the same problem. High idle when you come to a stop light. It would idle at about 1250 RPM. I looked at everything listed in this forum and finally found the EGR valve full of carbon and gunk. I just replaced it and the problem went away. I just wanted to post on here to thank you guys for your helpful information.
Reply With Quote
  #27  
Old 04-23-2014, 11:14 AM
rang-a-stang rang-a-stang is offline
Learning to use the forums
 
Join Date: Apr 2014
Posts: 5
Default Re: High Idle problems

My 1992 3.0 5 speed has this same issue. Here's what i see on mine.

I have no codes from KOEO or KOER. WHen it's stone cold, it idles correctly. As soon as it warms up at all, it heads north of 2000rpm. I replaced the IAC with no change. I notice that if i disconnect the IAC when the idle is high, it immediately drops to about a nice even 700rpm which tells me the computer is telling it to idle at 2000rpm.

WHen i run KOER or cylinder balance test it all works correctly. In fact, if i insert my test jumper, the idle drops. It also dropped to normal when I pulled my timing spout. Timing is set to 8 BTDC.

At lunch today i will be cleaning my EGR though I doubt this has anything to do with my idle. I also have not tried my A/C to see if that has any effect. I will check that today too. Anyone have any idea why my computer would be telling my truck to idle so high?

EDIT: I went out at lunch, i have no EGR. THere is a block off plate. I ran my KOEO and KOER and got a 172 and 176 in my KAM but the engine idled fine. friggin fraggin frocken, frigger. This thing is driving me nuts.

Last edited by rang-a-stang; 04-23-2014 at 12:51 PM.
Reply With Quote
  #28  
Old 04-23-2014, 06:55 PM
Clinton64xl Clinton64xl is offline
Ford Tough
 
Join Date: Jan 2014
Posts: 288
Send a message via Yahoo to Clinton64xl
Default Re: High Idle problems

Check your vacuum lines and intake manifold.. I have a intake manifold vacuum leak, i've gotta fix soon!! My truck idles real high around 1500 to 1800 rpms then idles real low sometimes where it's about to die.. I got a tip from a friend to spray some quick start or WD40 around my vacuum lines and around the intake manifold.. He said if i have a leak it will idle faster.. Well guess what? When i sprayed around the intake the idling got much higher.. So be sure you check the vacuum lines and intake..
__________________
ALL JACKED UP..... 4.0 V6 manual 5 speed, K&N cold air filter system, Helix high tower throttle body spacer, 33/12.50r15 BF Goodwrench A/T, 456 gears, 4" suspension lift, 3" body lift, james duff arms, fox racing shocks, superlift springs, dual exhaust, flowmaster super 10, Pioneer DEH-X9600BHS, Polk Audio MM series speakers and 10" subs, Polk Audio Amps, Rockford fosgate wiring and capacitor, Streetglow lights.. http://www.jamesduff.com/
http://streetglow.com
http://facebook.com/clinton64xl
Reply With Quote
  #29  
Old 04-23-2014, 07:01 PM
Cole_CT Cole_CT is offline
Ford Motor Co
 
Join Date: Jan 2014
Posts: 173
Default Re: High Idle problems

Quote:
Originally Posted by Clinton64xl View Post
Check your vacuum lines and intake manifold.. I have a intake manifold vacuum leak, i've gotta fix soon!! My truck idles real high around 1500 to 1800 rpms then idles real low sometimes where it's about to die.. I got a tip from a friend to spray some quick start or WD40 around my vacuum lines and around the intake manifold.. He said if i have a leak it will idle faster.. Well guess what? When i sprayed around the intake the idling got much higher.. So be sure you check the vacuum lines and intake..
This. Also clean your MAF and maybe change/clean your air filter. IAC might not be good just because it's new. Also your throttle body should be cleaned. The butterfly valve might not be closing all the way. It might be gunked up. Clean it with an old toothbrush and Throttle Body Cleaner.
__________________
- 2002 XLT Ext. Cab - 4.0L - FX4 - 4.10 LS - 31x10.5x15 GW A/T on Alcoas - Kenwood HU - Memphis Sub - Rockford Amp -
- Custom Whelen Reciever Light - Weatherguard Toolbox -
My Build Thread
Reply With Quote
  #30  
Old 04-24-2014, 09:17 AM
rang-a-stang rang-a-stang is offline
Learning to use the forums
 
Join Date: Apr 2014
Posts: 5
Default Re: High Idle problems

Quote:
Originally Posted by Cole_CT View Post
This. Also clean your MAF and maybe change/clean your air filter. IAC might not be good just because it's new. Also your throttle body should be cleaned. The butterfly valve might not be closing all the way. It might be gunked up. Clean it with an old toothbrush and Throttle Body Cleaner.
thank you for the responses Clinton64xl and Cole_CT


Will do (vaccum leaks). Air filter has about 1,000 miles on it. The throttle body was cleaned when i did the IAC replacement (about 800 miles ago).

Personally, i am not a huge fan of spraying very flamable chemicals around a running/warm engine. Usually to find vaccum leaks, i will unhook a a line, apply vaccum with a hand pump/guage and verify it holds. it presents a little less of a fire hazard and can be done when the engine is cold. I'll probably pull the upper/lower intakes and replace their gaskets just to be sure. The gaskets are cheap and my labor is free. it will also give me the chance to port match them.

I also saw on another forum last night, a guy had very similiar issues to me and found significant damage to the computer/harness connector. I will be checking that tonight, too.
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
89 2.9l high hydrocarbons and rough high idle dherndon99 2.9 Liter Tech 7 11-17-2010 05:50 AM
HELP! Rough idle/high rpms when stopping Scott 4-Cylinder Tech 11 08-20-2010 04:04 PM
2.3 high idle bob_rhoades78 4-Cylinder Tech 0 03-23-2010 06:31 PM
High idle in park!!!! POS1984ranger 2.9 Liter Tech 16 12-25-2009 06:48 PM
High idle & running rich RandSand 4.0 SOHC / 4.0 OHV Tech 2 10-08-2009 11:18 AM