Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 07-20-2013, 02:46 PM
USUaggie USUaggie is offline
Liking the Ford Ranger Forum
 
Join Date: Jun 2013
Posts: 15
Default Engine Turns but No Spark and No Start

In June I had my truck in at the mechanic for a whole month as they diagnosed and replaced "the computer". $440 ouch.
It ran like a dream for approximately an aggregate 20 hours (450 miles, 95% highway, 4% Dirt, 1% in town). Monday I traveling at 45mph down a sprayed dirt highway (that's Wyoming for ya) and suddenly without warning the truck cut out. Just wham - off. While I was still moving I put her in neutral turned the key and she ran again for another 100 yards and the same thing happened. After starting her one last time and she lasted just long enough for me to turn around to head back to the ranch.
After much hemming and hawing over it I discovered the fuel pump relay wasn't clicking and when I bridged it the fuel pump would run. So I replaced it. Still nothing works. This morning we checked for spark and I don't have any spark. So in a nutshell:

-Engine Turns over normally
-Fuel Pump Relay replaced
-Dash lights and radio turn on
-Head lights turn on
-When I turn the key I don't hear the fuel pump, but I do smell gas after turning it over (and we've done it repeatedly).
-All of the fuses in the box are good. #5 doesn't give a voltage reading but I pulled it out and it's fine.

This truck has died on me like this 3 times in the last 700 miles (that's once a month). Even worse, twice I've been in remote areas.

I'm flabbergasted. Any help/ideas?
__________________
'86 Ford Ranger FI 2.9L 4x4 5-speed LE

95 Yamaha xt225
Reply With Quote
  #2  
Old 07-21-2013, 10:55 AM
Psychopete Psychopete is offline
Psycho Pete
 
Join Date: Jun 2009
Posts: 1,489
Default Re: Engine Turns but No Spark and No Start

computer is what controls both - were the symptoms the same when they replaced the computer the first time?

start at the computer relay, make sure there is fused power and key on power. relay is testable, remove it, apply 12v to switch side and test connunity on the leads that connect fused power to computer. IIRC you could also swap relays and see if spark comes back. fuel is green, computer is brown.

also check the small ground that runs from the battery into the mainharness. ground to cab sounds like it's OK, but pull the kick panel and make sure the 60 pin wiring harness to the computer is secure, and check the ground there, too.

doesn't sound like it's "turning on"..

Last edited by Psychopete; 07-21-2013 at 10:57 AM.
Reply With Quote
  #3  
Old 07-21-2013, 11:07 AM
96_4x4_XLT 96_4x4_XLT is offline
Ford Ranger Driver
 
Join Date: Mar 2013
Posts: 6,189
Default

Quote:
Originally Posted by USUaggie View Post
In June I had my truck in at the mechanic for a whole month as they diagnosed and replaced "the computer". $440 ouch.
It ran like a dream for approximately an aggregate 20 hours (450 miles, 95% highway, 4% Dirt, 1% in town). Monday I traveling at 45mph down a sprayed dirt highway (that's Wyoming for ya) and suddenly without warning the truck cut out. Just wham - off. While I was still moving I put her in neutral turned the key and she ran again for another 100 yards and the same thing happened. After starting her one last time and she lasted just long enough for me to turn around to head back to the ranch.
After much hemming and hawing over it I discovered the fuel pump relay wasn't clicking and when I bridged it the fuel pump would run. So I replaced it. Still nothing works. This morning we checked for spark and I don't have any spark. So in a nutshell:

-Engine Turns over normally
-Fuel Pump Relay replaced
-Dash lights and radio turn on
-Head lights turn on
-When I turn the key I don't hear the fuel pump, but I do smell gas after turning it over (and we've done it repeatedly).
-All of the fuses in the box are good. #5 doesn't give a voltage reading but I pulled it out and it's fine.

This truck has died on me like this 3 times in the last 700 miles (that's once a month). Even worse, twice I've been in remote areas.

I'm flabbergasted. Any help/ideas?
Did you get the computer reflashed
__________________
95 Ranger XLT 4x2 2.3 I4 5 speed 206,000 *dead*
96 Ranger XLT 4x4 4.0 V6 5 speed 173,000 *alive*
D35 front, 8.8 rear, 3.73 gears, limited slip rear diff
Reply With Quote
  #4  
Old 07-22-2013, 07:10 AM
Psychopete Psychopete is offline
Psycho Pete
 
Join Date: Jun 2009
Posts: 1,489
Default Re: Engine Turns but No Spark and No Start

I think finding someone that can actually reflash that computer would be pretty difficult. we're talking 1986 tech here..
Reply With Quote
  #5  
Old 07-22-2013, 07:13 AM
djfllmn djfllmn is offline
ford dealer parts guy
 
Join Date: Apr 2011
Posts: 20,946
Send a message via AIM to djfllmn
Default Re: Engine Turns but No Spark and No Start

crank sensor take a shit?
__________________
2021 F150 5.0 Screw

Past:18 F150 2.7, 16 F150 5.0, 14 F150 5.0, 07 F150 5.4, 03 Ranger 4.0

Master Certified Ford Parts / Warranty Admin
Reply With Quote
  #6  
Old 07-22-2013, 07:16 AM
Psychopete Psychopete is offline
Psycho Pete
 
Join Date: Jun 2009
Posts: 1,489
Default Re: Engine Turns but No Spark and No Start

no crank sensor like EDIS, but the pick up in the dist sorta acts like one.
Reply With Quote
  #7  
Old 07-22-2013, 07:20 AM
modelageek modelageek is offline
Ford Ranger Driver
 
Join Date: Jan 2009
Posts: 6,268
Default Re: Engine Turns but No Spark and No Start

Quote:
Originally Posted by Psychopete View Post
no crank sensor like EDIS, but the pick up in the dist sorta acts like one.
I agree with psycho to replace the ecu relay. I also would suspect the ignition switch.
__________________
2004 Ext Cab, 4WD, 4.0, Auto, 154k. (4.0 engine is out of a 2009 Ranger w/96k) ( as of 7/1/2017)

2004 Ranger, Ext Cab, 2WD, 3.0, 5 speed , 4WABS, crank windows, no cruise, Edge 116k.(6/5,2014) (SOLD).
1999 Ford Ranger, Reg Cab, 2.5, 5 speed, 2WD, no AC, 150k (SOLD).
Reply With Quote
  #8  
Old 07-23-2013, 09:11 AM
USUaggie USUaggie is offline
Liking the Ford Ranger Forum
 
Join Date: Jun 2013
Posts: 15
Default Re: Engine Turns but No Spark and No Start

Alright. I will check the ECU relay, but as far as I know it is working properly because I can hear and feel it clicking when the key is turned.
Not sure how one would reflash the computer out here....or most places.
If the ignition switch is bad wouldn't it keep the starter from turning the engine over?

What are the symptoms of a bad coil? I've also been wondering if the coil has gone bad or a connection to it.
__________________
'86 Ford Ranger FI 2.9L 4x4 5-speed LE

95 Yamaha xt225
Reply With Quote
  #9  
Old 07-24-2013, 07:38 AM
Psychopete Psychopete is offline
Psycho Pete
 
Join Date: Jun 2009
Posts: 1,489
Default Re: Engine Turns but No Spark and No Start

still should pull the computer relay out and check for fused power. check ground and your 60 pin harness like I suggested. while you're there, check for 12 volts on pin #1 (big yellow wire). wouldn't think it's the coil because that would have nothing to do with the fuel pump priming. your symptoms seem consistent with the computer not powering on. probably wouldn't be much help to the actual issue, but pulling codes would be an easy way to sanity check the computer.
Reply With Quote
  #10  
Old 07-24-2013, 08:36 AM
EODIED EODIED is offline
Liking the Ford Ranger Forum
 
Join Date: Jul 2013
Posts: 15
Default Re: Engine Turns but No Spark and No Start

EECIV or first gen OBD computer in that one? I had a similiar issue in a 93 mazda, pulled the ECM (OBDII) found the burnt circuit solder a bridge into it and it ran fine after that.
__________________
2008 Ford Ranger 4x4 XLT 4.0 SOHC 5 Speed


"Light is faster than than sound, thats why most people appear bright until you hear them speak"
Reply With Quote
  #11  
Old 07-24-2013, 08:43 AM
Psychopete Psychopete is offline
Psycho Pete
 
Join Date: Jun 2009
Posts: 1,489
Default Re: Engine Turns but No Spark and No Start

these trucks and your '93 (unless someone did a major surgery) are both EEC-IV and OBD-I. though I thought the B-series was rebadged Ranger in '94, but could definitely be wrong.
Reply With Quote
  #12  
Old 07-24-2013, 08:44 AM
modelageek modelageek is offline
Ford Ranger Driver
 
Join Date: Jan 2009
Posts: 6,268
Default Re: Engine Turns but No Spark and No Start

Quote:
Originally Posted by USUaggie View Post
Alright. I will check the ECU relay, but as far as I know it is working properly because I can hear and feel it clicking when the key is turned.
Not sure how one would reflash the computer out here....or most places.
If the ignition switch is bad wouldn't it keep the starter from turning the engine over?

What are the symptoms of a bad coil? I've also been wondering if the coil has gone bad or a connection to it.
How do you know you are checking the ecu relay? Why would you pay $440 to not fix your old truck. The ecu cost $100 and takes 10 minutes to change. The relay cost $10 and takes 60 seconds. The ignition Switch cost $10 and takes 10 minutes.

Is your key cylinder sloppy?

Have you performed the wiggle test?

Have you checked/cleaned the
grounds?

PS. A bad ignition switch can have all kinds symptoms.
__________________
2004 Ext Cab, 4WD, 4.0, Auto, 154k. (4.0 engine is out of a 2009 Ranger w/96k) ( as of 7/1/2017)

2004 Ranger, Ext Cab, 2WD, 3.0, 5 speed , 4WABS, crank windows, no cruise, Edge 116k.(6/5,2014) (SOLD).
1999 Ford Ranger, Reg Cab, 2.5, 5 speed, 2WD, no AC, 150k (SOLD).

Last edited by modelageek; 07-24-2013 at 08:52 AM.
Reply With Quote
  #13  
Old 07-24-2013, 11:23 AM
USUaggie USUaggie is offline
Liking the Ford Ranger Forum
 
Join Date: Jun 2013
Posts: 15
Default Re: Engine Turns but No Spark and No Start

Checked all the relays and swapped them with the new one to test. They are all in working order as far as I can tell.
After an hour of poking around I have no idea where to look for this 60 pin harness. I've check on both sides of the firewall. Didn't even see anything capable of 60 pins. Biggest one I saw could maybe take ten.

Why would I spend $440? Because I don't have any experience whatsoever fixing cars. I think the most expensive part was the labor from the mechanic. I was expecting it to cost $800.

Key cylinder is not sloppy.

I haven't performed the "Wiggle Test". Haven't ever heard of it.

I have checked and cleaned several of the grounds but I don't know which ones to check or if I should every single one.
__________________
'86 Ford Ranger FI 2.9L 4x4 5-speed LE

95 Yamaha xt225
Reply With Quote
  #14  
Old 07-24-2013, 12:10 PM
Psychopete Psychopete is offline
Psycho Pete
 
Join Date: Jun 2009
Posts: 1,489
Default Re: Engine Turns but No Spark and No Start

it's under the passenger side kick panel, inside the truck. just because relay is clicking doesn't mean fused power is good (IIRC it will be yellow or yellow/black). just trying to offer a starting point as it doesn't sound like computer is turning on if you have both no spark and no fuel pump operation - it controls both. clicking EEC relay is a good sign that your ignition is fine, though.
Reply With Quote
  #15  
Old 07-25-2013, 11:02 AM
USUaggie USUaggie is offline
Liking the Ford Ranger Forum
 
Join Date: Jun 2013
Posts: 15
Default Re: Engine Turns but No Spark and No Start

Checked the yellow wire (or at least what i surmised as pin #1). Got normal voltage. What next?



----------

__________________
'86 Ford Ranger FI 2.9L 4x4 5-speed LE

95 Yamaha xt225
Reply With Quote
Reply

Tags
2.9l v6, fuel relay, no spark

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
will not start....turns over no gas to engine notunhappy Introduce Yourself 5 10-30-2012 03:33 PM
Engine Turns Over, But won`t start rhops 3.0 Vulcan Tech 4 12-04-2011 07:30 PM
Engine turns wont start - no fuel - no spark - pcm not powered! acheesebagel 4-Cylinder Tech 8 09-18-2011 12:31 PM
Truck will Not start, turns, spark, fuel good. details inside Doctor Wily 4-Cylinder Tech 8 03-22-2011 07:09 PM
engine turns but wont start vzmaradona 4-Cylinder Tech 4 12-04-2010 11:02 PM