Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 05-24-2013, 08:16 PM
Danny7 Danny7 is offline
Liking the Ford Ranger Forum
 
Join Date: Apr 2013
Posts: 25
Default Won't start when warm. Already relocated TFI

Hello all.

Truck has been running fine until it started getting warm out again. I relocated the tfi to the fender already. Truck will not start when warm.. What could this be? It starts when it has cooled off.
Reply With Quote
  #2  
Old 05-24-2013, 08:40 PM
StockBlueFord StockBlueFord is offline
Mr. MPG
 
Join Date: Feb 2012
Posts: 748
Default Re: Won't start when warm. Already relocated TFI

tfi?

What kind of truck? make a sig please.

Will it start after a few key cycles? could be low fuel pressure.
__________________
2011 Ranger XL Extended cab, 2x4, 2.3 L Duratec, Automatic, Mis-colored Leer camper shell, Ultragauge, LED plate bulbs, DDM "cree" reverse lights. Staying as stock as possible
Quote:
Originally Posted by robertmcclure View Post
and yeah, you wanna spend dat moneh on dat pusseh!
Reply With Quote
  #3  
Old 05-24-2013, 11:19 PM
Danny7 Danny7 is offline
Liking the Ford Ranger Forum
 
Join Date: Apr 2013
Posts: 25
Default Re: Won't start when warm. Already relocated TFI

87 ranger. I already relocated the tfi so it wouldn't heat up. After it still doesn't like to start when it is warm. It just cranks over. Good fuel pressure. Sparks when cooled off. Can the coil be bad? Haven't checked if it gets to warm yet,

----------

I tried it multiple times within 5 minutes when it was warm. Still nothing.
Reply With Quote
  #4  
Old 05-24-2013, 11:28 PM
63merc 63merc is offline
Ford Ranger Driver
 
Join Date: May 2012
Posts: 1,157
Default

Your coil may be bad.
Your timing may also be off
Reply With Quote
  #5  
Old 05-29-2013, 11:20 AM
Danny7 Danny7 is offline
Liking the Ford Ranger Forum
 
Join Date: Apr 2013
Posts: 25
Default Re: Won't start when warm. Already relocated TFI

Truck is running fine so the timing can't be off. Is the coil the only other possibility?

----------

I have to do a spark test straight off the coil after it doesn't want to start. Maybe that will narrow it down to the coil.
Reply With Quote
  #6  
Old 05-29-2013, 11:38 AM
63merc 63merc is offline
Ford Ranger Driver
 
Join Date: May 2012
Posts: 1,157
Default

Quote:
Originally Posted by Danny7 View Post
Truck is running fine so the timing can't be off. Is the coil the only other possibility?

----------

I have to do a spark test straight off the coil after it doesn't want to start. Maybe that will narrow it down to the coil.
If your getting gas then the only thing left is between distributor and coil.

The coil is my top guess.
Timing could still be possible. The truck runs good until its warm. So the truck is really not running so good. If the timing is advanced then you could have issues with warm starting. If its timed when its not at operating temp it will have problems when it's at operating temp

I would say coil but if that's not it I would look at timing next.
Reply With Quote
  #7  
Old 05-29-2013, 11:53 AM
Danny7 Danny7 is offline
Liking the Ford Ranger Forum
 
Join Date: Apr 2013
Posts: 25
Default Re: Won't start when warm. Already relocated TFI

I will pull out the handy dandy timing light and make sure it is timed correctly. Then we will go from there.
Reply With Quote
  #8  
Old 05-29-2013, 12:53 PM
Sub74 Sub74 is offline
Sub74
 
Join Date: Mar 2012
Posts: 512
Default

If you are getting a signal for the timing light then the coil, distributor, and pick- up are all working correctly
Leave the timing light hooked up to see if you are getting erratic spark as it quits
__________________
1988 Ranger STX, custom built flatbed, winch, 33x 10.5 BFG mudders
1974 Suburban (AKA "the sub") lockers front & rear, 383 cu in not even close to stock motor, snowplow 37 x 12.5 HUMMV tires, 4.56 gears
1952 M38 (CJ3) Jeep - my newest project - 289 ford, hardtop, got it with not one wire in it. Hope to have it driving this year
Reply With Quote
  #9  
Old 06-01-2013, 02:22 PM
Psychopete Psychopete is offline
Psycho Pete
 
Join Date: Jun 2009
Posts: 1,489
Default Re: Won't start when warm. Already relocated TFI

^^ good to check, ought to pull codes and look for either ignition related codes, MAP or coolant temp sensor
Reply With Quote
  #10  
Old 06-02-2013, 07:25 PM
Danny7 Danny7 is offline
Liking the Ford Ranger Forum
 
Join Date: Apr 2013
Posts: 25
Default Re: Won't start when warm. Already relocated TFI

So the other day my truck wouldn't start because it was warm. I connected a good spark plug on the wire coming from the coil. There was no spark. So that rules out timing. I was reading about those sensors and if they are bad will it prevent the coil from sendin spark?
Reply With Quote
  #11  
Old 06-02-2013, 08:27 PM
63merc 63merc is offline
Ford Ranger Driver
 
Join Date: May 2012
Posts: 1,157
Default

I don't think so. Before you go chasing those down try changing the ignition coil. Cheapest and easier route as of now
Reply With Quote
  #12  
Old 06-12-2013, 04:51 PM
Danny7 Danny7 is offline
Liking the Ford Ranger Forum
 
Join Date: Apr 2013
Posts: 25
Default Re: Won't start when warm. Already relocated TFI

Changed the coil. Didn't work. Bought a new tfi. Just installed it. Haven't tried repeated the problem yet. But I felt the bak of the tfi when it was running and is it supposed to get really hot. Like to hot to hold your fingers on? I haven't mounted it in a heat sink yet. I will have to go find one.
Reply With Quote
  #13  
Old 06-13-2013, 09:44 AM
Psychopete Psychopete is offline
Psycho Pete
 
Join Date: Jun 2009
Posts: 1,489
Default Re: Won't start when warm. Already relocated TFI

yes, you need to get a heat sink on that thing. if TFI is bad, relocating isn't going to fix a bad TFI module. they will fry if you install them on the dist with out heat compound. still think you should check stored memory codes once you get the TFI sorted out.
Reply With Quote
  #14  
Old 06-13-2013, 12:50 PM
Danny7 Danny7 is offline
Liking the Ford Ranger Forum
 
Join Date: Apr 2013
Posts: 25
Default Re: Won't start when warm. Already relocated TFI

New tfi didn't do anything. I put the old one on so I don't ruin the new one completely. Something else has to be wrong. Could it be the pip. I have to look at the stores codes yet too.
Reply With Quote
  #15  
Old 06-19-2013, 06:18 PM
Danny7 Danny7 is offline
Liking the Ford Ranger Forum
 
Join Date: Apr 2013
Posts: 25
Default Re: Won't start when warm. Already relocated TFI

Haven't looked at the codes yet but I got stuck the other day after going to the store. Truck would crank but would not start. I changed the tfi right there to a working one and it still did not start up. Tried a spark test and still no spark. I am getting so annoyed. I have tried a lot. Should be getting codes soon.
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Won't warm up, check engine light. CitySlick 4.0 SOHC / 4.0 OHV Tech 28 11-18-2012 07:05 AM
1988 Ford Ranger 6 cyl 2.9 won't start when warm consolegoddess 2.9 Liter Tech 29 08-03-2012 03:57 PM
93 4.0 won't drive when warm, idles fine? 727Designs General Tech 1 07-30-2012 07:29 AM
2002 ranger won't start when engine is warm Buster50 3.0 Vulcan Tech 3 12-30-2011 09:47 PM
Need Help won't run right until warm trshmn 4-Cylinder Tech 5 03-28-2011 04:30 PM