Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 02-24-2010, 06:46 PM
thomas2132 thomas2132 is offline
Liking the Ford Ranger Forum
 
Join Date: Feb 2010
Posts: 18
Default Fuel pressure loss

I have a 1987 2.9 V6. Two days ago I changed the fuel filter. After restarting the truck it ran great for about ten minutes and then shut off. It acted as if there was no fuel. I chalked this up to the possibility of air in the line. Is there a bleeding process that I was unaware of? I was towed toward home when I dropped it into first and dumped the clutch and it was off and running. Today, started up just fine, drove for almost 50 miles and parked. Came back a few hours later and it started right up then died within a few minutes. I checked the schrader valve on the injection rail and there was little to no fuel pressure. Had to use a few squirts of starting fluid before it finally fired and drove home without issue. I don't know if I need to replace fuel pump or what. Any help would be greatly appreciated.
__________________
Thomas Craft
Reply With Quote
  #2  
Old 02-25-2010, 12:35 AM
jester jester is offline
Ford Truck Driver
 
Join Date: Feb 2010
Posts: 76
Default

Sounds like the fuel pump to me. I had a 1989 xj that would have a hard time starting after sitting for a few hrs. Turns out there was a check valve in the pump that was bad so it would lose its prime
__________________
1993 Ford Ranger XLT, 4.0, auto, 4x4
No mods yet...
Reply With Quote
  #3  
Old 02-25-2010, 05:16 AM
modelageek modelageek is offline
Ford Ranger Driver
 
Join Date: Jan 2009
Posts: 6,257
Default

Did this problem exist at all before you changed the filter. DID YOU PUT THE FILTER FACING THE CORRECT DIRECTION?
__________________
2004 Ext Cab, 4WD, 4.0, Auto, 154k. (4.0 engine is out of a 2009 Ranger w/96k) ( as of 7/1/2017)

2004 Ranger, Ext Cab, 2WD, 3.0, 5 speed , 4WABS, crank windows, no cruise, Edge 116k.(6/5,2014) (SOLD).
1999 Ford Ranger, Reg Cab, 2.5, 5 speed, 2WD, no AC, 150k (SOLD).
Reply With Quote
  #4  
Old 02-25-2010, 04:44 PM
thomas2132 thomas2132 is offline
Liking the Ford Ranger Forum
 
Join Date: Feb 2010
Posts: 18
Default Reply to fuel pressure loss

The problem did not exist prior.
__________________
Thomas Craft
Reply With Quote
  #5  
Old 02-25-2010, 04:46 PM
modelageek modelageek is offline
Ford Ranger Driver
 
Join Date: Jan 2009
Posts: 6,257
Default

Quote:
Originally Posted by modelageek View Post
DID YOU PUT THE FILTER FACING THE CORRECT DIRECTION?

is the filter leaking at all?
__________________
2004 Ext Cab, 4WD, 4.0, Auto, 154k. (4.0 engine is out of a 2009 Ranger w/96k) ( as of 7/1/2017)

2004 Ranger, Ext Cab, 2WD, 3.0, 5 speed , 4WABS, crank windows, no cruise, Edge 116k.(6/5,2014) (SOLD).
1999 Ford Ranger, Reg Cab, 2.5, 5 speed, 2WD, no AC, 150k (SOLD).
Reply With Quote
  #6  
Old 02-25-2010, 04:47 PM
thomas2132 thomas2132 is offline
Liking the Ford Ranger Forum
 
Join Date: Feb 2010
Posts: 18
Default

No, and yes the filter was installed in the correct position
__________________
Thomas Craft
Reply With Quote
  #7  
Old 02-25-2010, 04:47 PM
modelageek modelageek is offline
Ford Ranger Driver
 
Join Date: Jan 2009
Posts: 6,257
Default

Quote:
Originally Posted by modelageek View Post
DID YOU PUT THE FILTER FACING THE CORRECT DIRECTION?
these forums are usless unless you respond to our questions!
__________________
2004 Ext Cab, 4WD, 4.0, Auto, 154k. (4.0 engine is out of a 2009 Ranger w/96k) ( as of 7/1/2017)

2004 Ranger, Ext Cab, 2WD, 3.0, 5 speed , 4WABS, crank windows, no cruise, Edge 116k.(6/5,2014) (SOLD).
1999 Ford Ranger, Reg Cab, 2.5, 5 speed, 2WD, no AC, 150k (SOLD).
Reply With Quote
  #8  
Old 02-25-2010, 04:48 PM
thomas2132 thomas2132 is offline
Liking the Ford Ranger Forum
 
Join Date: Feb 2010
Posts: 18
Default

The filter is not leaking
__________________
Thomas Craft
Reply With Quote
  #9  
Old 02-25-2010, 04:51 PM
modelageek modelageek is offline
Ford Ranger Driver
 
Join Date: Jan 2009
Posts: 6,257
Default

it is pretty strange that it was working fine . you changed the filter and then the truck acts up. I don't believe you need to bleed these. you don't have to bleed my 99. was the filter really dirty could some clog have loosened and clogged it worse?. if you can get a fuel pressure gauge and test it you want about 40
__________________
2004 Ext Cab, 4WD, 4.0, Auto, 154k. (4.0 engine is out of a 2009 Ranger w/96k) ( as of 7/1/2017)

2004 Ranger, Ext Cab, 2WD, 3.0, 5 speed , 4WABS, crank windows, no cruise, Edge 116k.(6/5,2014) (SOLD).
1999 Ford Ranger, Reg Cab, 2.5, 5 speed, 2WD, no AC, 150k (SOLD).
Reply With Quote
  #10  
Old 02-25-2010, 04:54 PM
modelageek modelageek is offline
Ford Ranger Driver
 
Join Date: Jan 2009
Posts: 6,257
Default

I wonder if the check valve got messed while you where changing the filter. did you put injector cleaner in the tank. if not put a couple bottles in there
__________________
2004 Ext Cab, 4WD, 4.0, Auto, 154k. (4.0 engine is out of a 2009 Ranger w/96k) ( as of 7/1/2017)

2004 Ranger, Ext Cab, 2WD, 3.0, 5 speed , 4WABS, crank windows, no cruise, Edge 116k.(6/5,2014) (SOLD).
1999 Ford Ranger, Reg Cab, 2.5, 5 speed, 2WD, no AC, 150k (SOLD).
Reply With Quote
  #11  
Old 02-25-2010, 04:58 PM
thomas2132 thomas2132 is offline
Liking the Ford Ranger Forum
 
Join Date: Feb 2010
Posts: 18
Default

Thanks, I'll add a bottle of cleaner and also check the pressure.
__________________
Thomas Craft
Reply With Quote
  #12  
Old 02-25-2010, 04:59 PM
modelageek modelageek is offline
Ford Ranger Driver
 
Join Date: Jan 2009
Posts: 6,257
Default

did you pull the relay when you changed the filter. if you did could it have gotten messed up?
__________________
2004 Ext Cab, 4WD, 4.0, Auto, 154k. (4.0 engine is out of a 2009 Ranger w/96k) ( as of 7/1/2017)

2004 Ranger, Ext Cab, 2WD, 3.0, 5 speed , 4WABS, crank windows, no cruise, Edge 116k.(6/5,2014) (SOLD).
1999 Ford Ranger, Reg Cab, 2.5, 5 speed, 2WD, no AC, 150k (SOLD).
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Lost fuel pressure thomas2132 Introduce Yourself 2 02-24-2010 09:37 PM
Fuel Pressure Test (help analyze my results) modelageek 4-Cylinder Tech 5 02-22-2010 12:28 PM
relieving fuel pressure RangerLuc General Ford Ranger Discussion 7 12-02-2009 05:38 PM
fuel pressure HandmedownRanger 4-Cylinder Tech 4 08-30-2009 08:21 PM
please help!!! the 94 lone ranger no fuel pressure loneranger General Ford Ranger Discussion 3 05-27-2009 04:37 PM