Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 04-16-2009, 08:24 PM
redneck_ranger_1991 redneck_ranger_1991 is offline
Learning to use the forums
 
Join Date: Apr 2009
Posts: 2
Send a message via Yahoo to redneck_ranger_1991
Default not running right

ok ive got a 91 with a 2.9 v6 idles smoothish but loses power when driving it backfires occasionally and seems like its missin but firing order is right could this be mositure in the distributor??? or what help me
Reply With Quote
  #2  
Old 04-26-2009, 11:10 PM
Airtruksrus Airtruksrus is offline
Ford Tough
 
Join Date: Apr 2009
Posts: 347
Send a message via Yahoo to Airtruksrus
Default

Tried adjusting the timing lately, happened when mine was adjusted about 15 to 17 degrees before i got a hold of a timing light. It backfired quite a bit when giving more than half throttle.
__________________
87 Ranger
5.0 (306) from worn out gt mustang
Exploder 31 spline tracloc,linelockin 3:55 rear w/discs
S & R Customs in the works...

PNW Crew...
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
3.0 major running problems bvallerand 3.0 Vulcan Tech 2 06-26-2009 07:56 PM
wont stay running Lila General Ford Ranger Discussion 4 05-06-2009 04:04 PM
Running HOTT Rangerman General Ford Ranger Discussion 3 03-04-2009 06:54 PM
2000 Ford Ranger 4.0L running too cold? BrettH8sU General Ford Ranger Discussion 1 02-01-2009 06:38 PM
what would cause my 88 ranger pickup to take long to warm up before running right.? smiles General Ford Ranger Discussion 2 11-26-2008 11:58 PM