Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > Engine Tech Forum > 6-Cylinder Tech > 2.9 Liter Tech
Forgot Password? Join Us!


Reply
 
LinkBack Thread Tools Search this Thread

  #1  
Old 01-30-2012, 07:25 PM
Learning to use the forums
 
Join Date: Jan 2012
Posts: 4
Default 1987 ford ranger speedometer not Working NEED HELP ASAP

well i just got a ford ranger 1987 2.9 liter it has right fender damage
im only mentioning this because i been trying to figure out what has gone wrong with my speedometer it stays at zero all the time i already checked the speedo cable and instrument cluster and everything seems to be working dose anyone know what needs to be connected for speedometer to work fyi my gas gauge is doing the same thing it may be related
Reply With Quote
  #2  
Old 01-31-2012, 10:58 AM
Psycho Pete
 
Join Date: Jun 2009
Posts: 1,487
Default Re: 1987 ford ranger speedometer not Working NEED HELP ASAP

if the cable and cluster are good, the next thing to check is the plastic gear on the end of the speed sensor that goes into the side of the transmission. Unbolt the retainer and it just pulls strait out.

Edit:
your speedometer is mechanical and your fuel level is electrical; these are probably two independent problems.

If the coolant temp gauge and oil pressure gauges are working, I would assume that the 5 volt regulator is OK. Float could be full of gas. Bad sending unit. Bad connection on the tank plug, or bad ground.
__________________

1987 Ford Ranger Short Bed 5.0L/T-5 Project
1988 Ford Ranger Long Bed Parts Truck
1993 Ford Tempo 2.3L OHV HSC Auto - D/D Stock.
1999 Honda Accord VTEC Auto
2002 Dodge Caravan - 3.3L Auto

Last edited by Psychopete; 01-31-2012 at 11:05 AM.
Reply With Quote
  #3  
Old 01-31-2012, 12:20 PM
Liking the Ford Ranger Forum
 
Join Date: Dec 2011
Posts: 29
Default Re: 1987 ford ranger speedometer not Working NEED HELP ASAP

i would guess open wire somewere. the speedo check the linkage
Reply With Quote
  #4  
Old 01-31-2012, 09:14 PM
Learning to use the forums
 
Join Date: Jan 2012
Posts: 4
Default Re: 1987 ford ranger speedometer not Working NEED HELP ASAP

i checked the speed sensor pulled out the cable on the cluster and transmission to see if the needle would spin if i turned in Manually . that was good.
question? does the speedometer need power to run there is 3 cables running lose in right behind the cluster under the hood one is red with a white clip on it the other 2 are blue
second there in a loose cable under the vehicle its a female connector with 2 holes i have no idea what these do i am thinking it has something to do with my issues


by the way thanks for responding
Reply With Quote
  #5  
Old 12-07-2012, 02:05 AM
83 pos ranger
 
Join Date: Nov 2012
Posts: 38
Default

My 83 has that issue lol! The old lady wants it fixed, so I pulled the plastic cover off the spedo, when driving if I move the needle up it works fine. Stop and it sticks again. Lubed the cable, nothing, except the noise @ 60 is gone lol. Instead of a new spedo I'm going to drill a little hole just under the needle and stick in a stop so it won't go all the way down. Kinda cheese, I know but wth? Any input?
Reply With Quote
Reply

Tags
1987 speedo speedometer

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Ford Ranger Speedometer quit working? wrongfulleaf Electrical Tech 28 09-11-2013 07:49 PM
need speedometer warning light help ASAP ivz 3.0 Vulcan Tech 0 01-06-2011 03:27 PM
speedometer not working right cheeba Electrical Tech 6 10-27-2010 07:12 PM
speedometer not working ngant17 Drivetrain Tech 0 05-30-2010 07:55 AM
speedometer quit working blackandgreen98 Electrical Tech 5 01-22-2010 10:56 AM



Search Engine Friendly URLs by vBSEO 3.6.0 ©2011, Crawlability, Inc.