Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 07-02-2011, 09:56 AM
fyresq fyresq is offline
Learning to use the forums
 
Join Date: Jul 2011
Posts: 4
Default 88 2.9 running like crap!

I have an 88 2.9 5 speed 4x4 180k that won't run right. The down and dirty is this - I've tried everything that I can think of so I need some suggestions.

The truck has fuel pressure (30-40 constant) and will start but runs at ~500rpm, wants to die and you can't rev it - like it's starving for fuel. If you play with the throttle for a while it will kick open and run at wide open throttle but within 10 seconds will drop down to 500 rpm again even with the accelerator mashed to the floor.

Things done so far:
New fuel with stabilizer and amsoil additive for any old fuel plus injector cleaner
The truck now reads code 11 - system ok
replaced map/maf sensor
replaced TPS sensor
replaced Fuel pressure regulator (reads 30-40 psi)
replaced IAC sensor and motor
replaced fuel filter
replaced distributor cap, wires, and plugs
I've tried to check for vacuum leaks and sprayed carb/injector cleaner all over to see if the idle would pick up due to leak - nothing

I've thought of the coil (has aftermarket autometer on it), cat (but the idle surges up and down), injectors (but why does it all of a sudden go to wide open throttle if they were clogged?)

I'm tired of throwing parts and money at this thing, any suggestions other than insuring at full coverage and setting it on fire?

I've searched this and several other forums and there is no firm answer to my issue
Reply With Quote
  #2  
Old 07-02-2011, 09:58 AM
djfllmn djfllmn is offline
ford dealer parts guy
 
Join Date: Apr 2011
Posts: 20,770
Send a message via AIM to djfllmn
Default Re: 88 2.9 running like crap!

i didnt see anything about a fuel pump..maybe do that and see if that helps
__________________
2016 F150 Supercrew XLT 5.0
1968 Ford Thunderbird Tudor 429 Thunderjet V8

(Click for Project Log)

traded-2007 F150 XLT Supercab 5.4
Sold:03 Sonic Blue FX4 Steppie 4.0SOHC 5spd
ranger free since 6/15/2012

Quote:
Originally Posted by Logan03CO View Post
These threads make me feel better about myself....
Quote:
Originally Posted by guell View Post
Welcome to the internet, if this is your first visit to it I suggest you stock up on a lot of preparation h cause you gonna be butt hurt a lot
Reply With Quote
  #3  
Old 07-02-2011, 04:45 PM
fyresq fyresq is offline
Learning to use the forums
 
Join Date: Jul 2011
Posts: 4
Default Re: 88 2.9 running like crap!

I have avoided buying the two fuel pumps (at $200+) since I have 30-40psi on the fuel rail.
Reply With Quote
  #4  
Old 07-02-2011, 06:23 PM
Fordzilla80 Fordzilla80 is offline
Welcome to FRF!
 
Join Date: Oct 2010
Posts: 8,952
Default Re: 88 2.9 running like crap!

Are the plugs gapped correctly?

Checked the distributor housing for cracks?
Reply With Quote
  #5  
Old 07-02-2011, 06:31 PM
tmoore78 tmoore78 is offline
Ford Ranger Driver
 
Join Date: Oct 2010
Posts: 981
Default Re: 88 2.9 running like crap!

"If you play with the throttle for a while"
from under the hood or pedal?
__________________
2007 FORD RANGER XLT EXTENDED CAB - 4.0, 4x4, 5sp
Ultragauge, 10" L7 W/ 2200W PA Amp, CB W/4' Fiberglass whip, PA system, LEER shell w/led 3rd brake and custom remover, LED taillights in mudflaps, 5K 55W HIDs, Aux reverse lights, DIY bed liner, Hellas, Bed mat (cut up livestock mat).


Quote:
Originally Posted by 2004xlmiller View Post
yea with 4.10s a 3.slow and 33s it will be a 3.dudegetthefuckouttamywayyouresoslow
Reply With Quote
  #6  
Old 07-03-2011, 02:45 PM
fyresq fyresq is offline
Learning to use the forums
 
Join Date: Jul 2011
Posts: 4
Default Re: 88 2.9 running like crap!

from either pedal or under hood. It has a new distributor cap, plugs (gapped) and wires
Reply With Quote
  #7  
Old 07-09-2011, 06:55 AM
88owner 88owner is offline
Learning to use the forums
 
Join Date: Jul 2011
Posts: 3
Default Re: 88 2.9 running like crap!

I had an 89 that done the same thing but i replaced the IAC and fixed it have you checked the fuel pump to make sure it had proper pressure.
__________________
i have owned a 1989,91,92,96 and 2003 ranger all
4wd i am now the proud owner of a ticking 1988 ranger xlt et cab 4wd with a 3'' lift and 2.9 v6 paint job is rino liner and camo.
Reply With Quote
  #8  
Old 07-11-2011, 08:44 AM
fyresq fyresq is offline
Learning to use the forums
 
Join Date: Jul 2011
Posts: 4
Default Re: 88 2.9 running like crap!

In the original post-
"has 30-40 psi fuel pressure"
"replaced IAC sensor and motor"
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
runs like crap sometimes??? tchmstr General Tech 1 01-20-2011 12:59 PM
crap haha Cstalls Exterior Tech 8 12-16-2010 01:57 PM
so listen too this crap.......and help if u can please lostsoul 4.0 SOHC / 4.0 OHV Tech 2 10-07-2010 11:50 AM
Holy crap! EMB1230 General Ford Ranger Discussion 4 09-28-2010 10:01 PM
holy crap Superlifted06FX4 Off Topic 7 09-27-2009 08:11 AM