Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 04-12-2011, 04:52 PM
dksob81 dksob81 is offline
Learning to use the forums
 
Join Date: Apr 2011
Posts: 3
Default 90 ranger 2.9L Loses oil pressure and runs rough

I am working on a 1990 Ford Ranger 2.9L 4WD.
After driving 20 minutes or so it starts running rough and looses oil pressure, it does have a constant ticking/tapping (Valve/Lifter/Pushrod), I am pretty sure it is pinging when the issue occurs, the truck is very loud (exhaust, or lack there of....lol) but I can hear the the pinging over the exhaust. Not sure if it is overheating, temp guage doesn't work along with the fuel level guage.

Any ideas, suggestions, etc....
Thank You
Joe

P.S...I did see someone else had this issue on yahoo or answer.com but no solution was posted.
Reply With Quote
  #2  
Old 04-15-2011, 08:09 AM
Psychopete Psychopete is offline
Psycho Pete
 
Join Date: Jun 2009
Posts: 1,489
Default Re: 90 ranger 2.9L Loses oil pressure and runs rough

Need to get an aftermarket gauge on that thing and check the specs. Try and ground the temp sensor wire and see if the temp gauge reads full hot. If pressure is really dropping off, could be pick up clogging up, pump tolerances too loose (worn out), or the engine tolerances are too large (worn out). Hard to say for sure, best to get an opinion from someone with a good ear for engine noises. These engines are notorious for lifter ticks, and the oil system is known to be problematic. The rocker arm shafts tend to plug up as well. Regular maintenance is very critical.
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Tire loses pressure.... FX4 Mike Wheels and Tires 12 03-24-2011 09:17 AM
87 ranger 2.9 runs rough when warm mossyoakranger99 General Tech 5 12-08-2010 10:33 AM
Ranger runs rough wedge 4-Cylinder Tech 0 08-16-2010 11:17 AM
ranger runs rough smokes alot here and there 94 Ranger 3.0 Vulcan Tech 10 05-10-2010 04:46 PM
1998 Ford Ranger runs rough with sulfur smell? Michael K General Ford Ranger Discussion 1 01-01-2009 01:57 PM