Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Thread Tools Search this Thread

Old 01-18-2011, 07:51 AM
olefafl olefafl is offline
Learning to use the forums
Join Date: Dec 2010
Posts: 1
Default 1989 2.9 Not starting

Right before New Years the truck died about 5 miles after I left home. Towed it home and started checking stuff.
I had spark and fuel at the rail.
While checking stuff over it started, not sure why.
Moved truck about 15ft and hosed motor off to clean it up. I had only owned the truck for about 1 month and the motor was nasty and it was a warm day here.
After hosing it off it would not start, but now it didn't have spark. Changed out the ICM (old one tested bad) and it still would not start, pulled it back off to have the new one tested, it was good. Reinstalled the new one and it started and ran fine till today.
I have spark and fuel (don't have a pressure gauge at home, its at work).
Just put a new cap & rotor on and still no start.

It was just starting to rain the first time it died and its been raining today, so I bet something is getting wet.
Its my plow truck and it was snowed and rained sence New Years, but I didn't have any trouble till today.
Any ideas?

Last edited by olefafl; 01-18-2011 at 08:00 AM.
Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar Threads
Thread Thread Starter Forum Replies Last Post
I need help! 1989 2.9 v6 tiemann66 2.9 Liter Tech 26 08-15-2011 01:25 PM
1989 2.3L Seafoam? deerman2701 4-Cylinder Tech 1 08-13-2010 10:00 AM
1989 2.3 plugs deerman2701 4-Cylinder Tech 2 08-10-2010 05:48 PM
1989 Ranger Issue kitt1993 4-Cylinder Tech 3 08-09-2010 06:50 PM
1989 seats in 1994? blindman_10 Interior Tech 2 02-25-2010 02:18 PM