Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 11-19-2010, 09:25 PM
teal9550 teal9550 is offline
Learning to use the forums
 
Join Date: Nov 2010
Posts: 3
Default sevral issues

truck is a 91 4x4 auto 2.9l super cab, the problem is i have to crank it and step on the gas several times before it will start, ive cleaned the iac, changed the tps, cleaned the tb the fuel presure is about 30psi at idle any idea
Reply With Quote
  #2  
Old 11-19-2010, 09:40 PM
2002 2WD Edge 2002 2WD Edge is offline
Ford Tough
 
Join Date: Mar 2010
Posts: 387
Default Re: sevral issues

But it is fuel injected? If so you shouldn't be pumping the gas, but keep your foot off,.. and with a cold motor it should fire up into a fast idle. It may be pre-platinum plugs...and the plugs could need replacing. Go for platinum ones and you shouldn't have to do it a 2nd time. It's old enough the plug wires could use replacing. Check the air filter too. These things don't cost much if you do it yourself and they would all be good for a long time. Get the battery checked. Should be able to get that done for free..ideally from a place you already know and trust,..otherwise you'll likey be told you need one. Take it from there if it's no better.
__________________
JBA s.s. headers&exhaust, K&N cold air intake, Bosch Iridium Plus 4 plugs, Royal Purple in motor, 5spd & diff.,Superchips programmer, axle girdle. Also have but yet to install KYB Gas-A-Just shocks and Belltech sway bars.
Reply With Quote
  #3  
Old 11-20-2010, 01:46 PM
teal9550 teal9550 is offline
Learning to use the forums
 
Join Date: Nov 2010
Posts: 3
Default Re: sevral issues

I guess I should have mention that I just did cap,rotor , plugs & wires. I've got to think it's a clogged fuel filter or a week pump I was just wondered if anyone else had this issue & how it was resloved
Reply With Quote
  #4  
Old 11-22-2010, 07:58 AM
Psychopete Psychopete is offline
Psycho Pete
 
Join Date: Jun 2009
Posts: 1,489
Default Re: sevral issues

Lots of things can cause that off the top of my head. I would start by checking for trouble codes to see if any sensors are out of range enough that the computer threw a code. Then check MAP, TPS, and the ECT. Check for distributor shaft play. Noid light on the injectors to make sure they're working when cranking.

http://www.fordfuelinjection.com
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
wiper issues DieselBrad Electrical Tech 5 01-06-2011 06:37 PM
Vacuumm issues 1973truckman 2.9 Liter Tech 1 05-19-2010 06:46 AM
issues jjanak79 Drivetrain Tech 0 01-11-2010 03:19 PM
heater issues stvtackett 3.0 Vulcan Tech 1 01-07-2010 08:36 PM
heater issues stvtackett General Tech 0 01-04-2010 05:34 AM