Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 08-19-2017, 12:59 PM
boatman8 boatman8 is offline
Learning to use the forums
 
Join Date: Aug 2017
Posts: 2
Default 2.9 V-6 antifreeze in oil

I have a 1990 Ranger with 2.9 V-6. Went to change oil and when I loosened the drain plug, straight antifreeze came out around the threads. It wasn't milky looking oil, so it must have just happened. Motor seems to run fine like always, but I am wondering where the most likely place is that the antifreeze is getting in at. I'm not using the truck until I get the problem fixed. I had both heads replaced under warranty years ago because one was cracked. Are the new replacement heads made better than the original ones were? Any advice would be much appreciated.
Reply With Quote
  #2  
Old 08-19-2017, 04:34 PM
Grumpa Grumpa is offline
Busted Knuckles
 
Join Date: Mar 2016
Posts: 210
Default Re: 2.9 V-6 antifreeze in oil

Some of the more obvious culprits could be.. loose intake manifold bolts causing gasket failure, failed head gasket(s), or cracked heads, cracked intake manifold, internal crack in the block, timing chain cover and/or gasket. I myself in this situation would check to see if I had any loose intake manifold bolts first, especially where the cooling jackets are. You might get lucky and just have to replace that gasket.
__________________
1995 Ranger XLT 3.0L OBDII
Trans: A4LD (E) 2WD
Rear: 7.5 / 3.45 NL LHD
Tires:GY P235 75/R15 (orig 225 70/R14)
Long Bed, 20 Gal Tank
Up to 225,500 miles
Reply With Quote
  #3  
Old 08-20-2017, 12:11 AM
boatman8 boatman8 is offline
Learning to use the forums
 
Join Date: Aug 2017
Posts: 2
Default Re: 2.9 V-6 antifreeze in oil

Thanks for your reply. I pulled off the plenum and the intake manifold. For some reason the two back ports of the intake manifold are purple color inside... the other ports all look normal. I don't know if that is related to my problem of getting antifreeze in the oil? There is no real sign of the intake gasket leaking and I don't see any cracks in the intake manifold. I think I will get it magnafluxed and see if anything shows up. Thanks again for your help.
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Antifreeze issues?? JLDANGER RANGER 4-Cylinder Tech 27 12-16-2013 05:09 PM
Leaking antifreeze DayneR 4-Cylinder Tech 6 10-02-2013 06:44 PM
antifreeze?? Eagle General Tech 1 11-13-2011 07:32 PM
Antifreeze/oil....help anyone?? DaRayvn General Ford Ranger Discussion 5 08-29-2010 08:21 PM
Which Antifreeze Keith_C 4.0 SOHC / 4.0 OHV Tech 2 04-05-2010 11:03 PM