Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 01-23-2017, 07:57 PM
Dgoon Dgoon is offline
Learning to use the forums
 
Join Date: Jun 2015
Posts: 2
Talking 88 Ranger Engine Running/ No restart for 15 minutes

cold start runs good as soon as you shut it off will not re start for 10-15 min will only crank. while cranking it maintains fuel pressure at 40 psi when running it maintains 32 psi. it doesn't matter if the truck runs for 2 min or 30 once you shut it off will not start back up for a short time. i have put in both fuel pumps new filter spark plug coil swapped out the fuel pressure regulator and air switch
__________________
88 Ranger 2.9 5 speed 4X4 4" lift 33" tires
Reply With Quote
  #2  
Old 01-24-2017, 06:38 AM
tenro tenro is offline
Si Vis Pacem, Para Bellum
 
Join Date: Sep 2016
Posts: 85
Default Re: 88 Ranger Engine Running/ No restart for 15 minutes

Have you changed the TFI Module on the distributor? The repeated heating and cooling kills them over time and eventually they'll start doing this and then the truck will just start randomly shutting off and progressing towards not starting at all. That or the PIP(Profile Ignition Pickup) inside the distributor. My bet is the TFI module, also known as, ignition control module.
__________________
'83 F100 XLT RC/SB, 5.0, AOD, Factory Tach, American Racing wheels, 3.08 gears, Mustang Roller Cam with Cam Advance, Stainless Shorties, Edelbrock 1403 carb, 289 D-Code 4bbl intake. AOD to C6 swap in progress. <--- Build Thread

'86 F150 RC/LB 4x4, 4.9, Np435, Np208, 3.08
Reply With Quote
  #3  
Old 01-24-2017, 05:59 PM
Dgoon Dgoon is offline
Learning to use the forums
 
Join Date: Jun 2015
Posts: 2
Default 88 Ranger Engine Running/ No restart for 15 minutes

i replaced the tfi and the map sensor along with tps sensor today and still no luck it got worse now it doesn't want to start at all so all and all this week i have replaced with new parts

1 low pressure pump

2 hi pressure pump

3 fuel filter

4 coil

5 tfi

6 tps

7 map
8 spark plugs

swapped from another motor

1 fuel pressure regulator

2 air bypass valve

the truck holds fuel pressure at 39 psi wail trying to start and holds it there and with the spark tester on at the coil it has constant spark wail trying to start i have taken the ecu apart very clean both outside and in with a flashlight i inspected it no burnt resisters no water or damage of anything but i have not tested or changed the part in the distributor

so i really appreciate any and all help as this is a father son project and he got his licence 4 day ago so the pressure is on thanks again
__________________
88 Ranger 2.9 5 speed 4X4 4" lift 33" tires

Last edited by Dgoon; 01-24-2017 at 06:11 PM.
Reply With Quote
Reply

Tags
2.9, no hot start, no restart

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Engine shuts off after 2 to 5 minutes Steve McKinley 4.0 SOHC / 4.0 OHV Tech 4 03-19-2015 12:52 PM
86 Ranger 2.3 - Gas will not keep engine running. bozo4ford 4-Cylinder Tech 11 11-14-2012 09:15 AM
1998 Ford Ranger Engine Cutout and Restart aschramm 4-Cylinder Tech 2 12-12-2011 12:22 PM
3.0l v6 4x4 wont restart after the engine warms up? rangerpayne 3.0 Vulcan Tech 1 07-07-2011 09:12 AM
Engine won't keep running for more than 2-3 minutes tomandcharidy 4-Cylinder Tech 7 12-17-2010 10:37 AM