Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 05-23-2010, 07:59 PM
TheStig TheStig is offline
My truck snorts.
 
Join Date: Sep 2009
Posts: 820
Default BII with idle issues

buddy of mine has a 1988 BII with 2.9 w/auto trans
and 140k on it

IAC....TPS....coolant temp sensor have been replaced

the problem is that it won't idle....accelerating from a stop it wants to fall on its face and it spits and sputters.

once it gets up to speed or just give it more than 25% throttle, it has zero problems....runs like a champ

its just at idle it seems that is running way too rich and we can't figure out why

any ideas?
__________________
1996 XLT 2.3T "White Lightning" 5/7 dropped, Turbo street toy
2006 FX4 Off Road, DD, work in progress
1985 XLT 2.8L 4x4 "The Black Pearl" (retired but still around)
1987 XL 2.3L 2wd R.I.P.
Quote:
Originally Posted by RangerAllie View Post
I love me some Stig
Reply With Quote
  #2  
Old 05-23-2010, 08:22 PM
edgeman4.0 edgeman4.0 is offline
THE COMPLAINT DEPARTMENT
 
Join Date: Nov 2009
Posts: 3,962
Default Re: BII with idle issues

Spark or fuel systems been checked?
__________________
2001 Ford Ranger Supercab (4dr), Oxford White, 4.0 Sohc, 4x4, Manual trans (hurst equipped), 4:10's, 3" body lift.
Quote:
Originally Posted by Demon-FX4 View Post
The Edgeman sees his prey and strikes out from the darkness.
Quote:
Originally Posted by Rango88 View Post
Dont f+ck with Ch+ck
Reply With Quote
  #3  
Old 05-23-2010, 08:46 PM
littleblue littleblue is offline
Semper Paratus
 
Join Date: May 2009
Posts: 274
Default Re: BII with idle issues

I had a 90 bii that did the same thing. The check engine light would turn on/off intermittently and throw a code(can't remember which one) that indicated an ignition problem. Tuned it up, replaced the coil, fuel pressure regulator, ignition module(on distributor), fuel filter, and on and on based on info provided from different forums. Still wouldn't idle right. Finally replaced the 02 sensor and the problem was fixed.
__________________
'00 XLT 3.0 Exted cab
Mods: Roush hood & cai, ASP pwr pulley, hot wtr bypass, 180 therm, e-fan, Gibson exh., 4.10 l/s, FabTech lift, kyb's, bii sway bar. 31x10.50 Yokahama ATs, Panther rims, light bar, SS grille, 03 stang buckets, explorer console, hurst shifter


http://www.cardomain.com/ride/706028/1
Reply With Quote
  #4  
Old 05-23-2010, 08:59 PM
TheStig TheStig is offline
My truck snorts.
 
Join Date: Sep 2009
Posts: 820
Default Re: BII with idle issues

Quote:
Originally Posted by edgeman4.0 View Post
Spark or fuel systems been checked?

fuel pump is being replaced on the 1st

dunno about ignition system....i'll ask him when i see him
__________________
1996 XLT 2.3T "White Lightning" 5/7 dropped, Turbo street toy
2006 FX4 Off Road, DD, work in progress
1985 XLT 2.8L 4x4 "The Black Pearl" (retired but still around)
1987 XL 2.3L 2wd R.I.P.
Quote:
Originally Posted by RangerAllie View Post
I love me some Stig
Reply With Quote
  #5  
Old 05-24-2010, 07:15 AM
Psychopete Psychopete is offline
Psycho Pete
 
Join Date: Jun 2009
Posts: 1,489
Default Re: BII with idle issues

I agree, fuel pressure test would definitely give a good clue on if that is contributing to the problem. Have you tried to pull codes from the computer for any clues on which system is malfunctioning?
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
pink BII dixie_boysles Vehicle Snapshots 4 04-02-2010 08:25 PM
[SOLD] bII bronco 1" rear swaybar - 50 (CA) smakes Suspension Parts 8 02-01-2010 12:02 PM
issues jjanak79 Drivetrain Tech 0 01-11-2010 03:19 PM
06 4.0 mileage issues Superlifted06FX4 4.0 SOHC / 4.0 OHV Tech 16 12-03-2009 11:31 AM
New truck...new issues RANGER @ GT Electrical Tech 10 09-09-2009 12:34 AM