Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 12-27-2013, 02:42 PM
Rangernasty4x4 Rangernasty4x4 is offline
Learning to use the forums
 
Join Date: Dec 2013
Posts: 5
Default running rich, shuddering, bucking, surging 2.9

Couldn't find any info on this particularly, but I think its a combination of a few other problems. Anyway, I'm used to carburetors, I'm not savvy about all these sensors and what not, but I can find my way around common ford sensors.

I bought a 92 2.9 4x4. Its always been alittle sluggish. It has a misfire (haven't narrowed it down to a cylinder yet). I have all motorcraft tune up parts coming in the mail so I'll see if that changes anything.

It'll be hard to start sometimes when cold (which i'm assuming is just the fuel pressure not holding). It idles okay, but it has a misfire so it shakes around etc. Sometimes when it sits for awhile and I first gas it, it'll just flat out die, unless I really step on it, then it hesitates for a good second before it takes off. I cleaned the IAC and this stopped for about a week and now it starting to act up again.

The misfire happens 90% of the time. Since it runs sluggish you really need to put your foot into it to get it to accelerate at a normal pace. Sometimes when i'm at a redlight and push the pedal down normally to accelerate at a normal pace, it'll light up the tires and take off like i'm flooring it and I wont hear the miss. then when I let off the gas pedal and ease back into it, it'll accelerate normally (slowly) and still have the miss.

Other times when I push the pedal it'll accelerate normally (as in slowly) and for a few seconds at a time the miss will go away and it'll accelerate like i'm flooring it, then dog, then floor it, then dog, in about 1 second intervals without moving the pedal at all (surging, I guess you would call it?). Then when it hits speed it'll run normally(as in missifre).

This problem I think may be un-related. Driving at speed totally randomly, (normally anywhere between 45-60) it'll start shuttering, like a really bad case of an out of balance tire. Sometimes bad enough the stuff on the dash starts bouncing up and down. If it gas it enough for it to downshift it'll stop shuttering, and if I lay off the gas it will stop shuttering. its only trying to hold a constant speed. If it stop at a stop sign, or slow reduce speed for a few miles, when I get back to cruising speed, it might do it again, it might not. Its totally random.

Another problem it has...at speed (between 45-60) it'll buck pretty hard. Kind of like cruising, pushing in the clutch, reving the engine and dumping the clutch. it'll just coast for a half second and slam back into gear. At first I thought maybe it was the transmission banging in and out of overdrive, but a closer listen told me its the rpm's dropping and then slamming back up. It'll do that randomly, about 10% of the time. sometimes it gets pretty violent though. Makes me scared I might lose a u-joint. I'm wondering if that's the "bucking bronco" problem.

Its getting about 9mpg currently, driving somewhat generously. Smells rich often times. I'm hoping the misfire is just an ignition problem and doesn't involve any injectors etc.

I plan on replacing the 02 when I do this tune up. Can anybody take this information and maybe point me to another sensor that may need cleaning or replaced? I'm going to clean the MAF tonight. I'll double check for vacuum leaks.
__________________
1992 Ranger nasty 2.9 auto 4x4
Reply With Quote
  #2  
Old 12-27-2013, 02:59 PM
Rangernasty4x4 Rangernasty4x4 is offline
Learning to use the forums
 
Join Date: Dec 2013
Posts: 5
Default Re: running rich, shuddering, bucking, surging 2.9

I'm also thinking this might be a fuel pressure problem, but at 9mpg i'd assume the fuel is flowing just fine...
__________________
1992 Ranger nasty 2.9 auto 4x4
Reply With Quote
  #3  
Old 12-30-2013, 11:05 AM
Fastfar Fastfar is offline
My other car: R1100GS
 
Join Date: Dec 2013
Posts: 8
Default

New to ford rangers myself, have been dealing with some of the same issues with my 86 2.9 EFI. One thing that helped is to get a code reader for your vehicle. In my case, an OBD-1. Most of the problems went away when I located a couple of minor vacuum leaks in hoses. I also replaced all ignition parts and filters and changed the oil. I go in for the smog test today so I'll see if I got it right...

So once you have read out the stored or active codes you'll have an idea which direction to go first. As you mentioned it could be several problems hiding in your package of symptoms. All I know how to do is find a place to start and keep picking at it until I figure it out. Code reader, shop manual, search the forums for similar reports and diligent patience...take notes too!
__________________
86' Ranger 4x4 5spd 2.9L V-6

Last edited by Fastfar; 12-30-2013 at 11:08 AM.
Reply With Quote
  #4  
Old 02-21-2014, 07:53 PM
More_Cowbell More_Cowbell is offline
Chrome Dont Get You Home
 
Join Date: Dec 2009
Posts: 1,169
Default Re: running rich, shuddering, bucking, surging 2.9

sorry to bump an old thread but have you checked your fuel pressure regulator? i was getting round 11mpg on my 2.9l and that went up to around 19 after i replaced that. there should be a vacuum line going from it to the upper intake mine had fuel coming out of that line so thats a quick thing you could check.
__________________
1990 Ranger Extended Cab
2.9L V6 5 Speed Transmission
Planning to put a 347 and a T-5 in it eventually

Quote:
Originally Posted by FireRanger View Post
It looks like someone attacked the front of the truck with a bedazzler.
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Weird bucking, shuddering feeling.. gcextreme General Tech 32 09-09-2013 06:14 PM
Running rich? ranger-owner-XLT 3.0 Vulcan Tech 8 04-14-2013 07:21 PM
Why running rich? Sub74 2.9 Liter Tech 55 01-02-2013 10:53 PM
running rich joker515 3.0 Vulcan Tech 0 02-26-2011 11:10 PM
3.0 running rich SmokeyMcPot420 3.0 Vulcan Tech 11 10-30-2009 09:46 PM